0

Hi guys,
thanks or having me at this forum hopefully i'll be able to help someone else one day but unfortunately its me who needs help atm.

Every time I try to play a higher end game (Command and conquer 3 / half life 2 / area 51) the games just crashes and terminates. I have updated all of the bios and graphics chipsets but still getting these prblems, i meet all of the minimum requirements or surpass them so i don't understand what the problem could be, could it be a video driver problem?

Thanks everyone,
Ryan :)

3
Contributors
11
Replies
12
Views
10 Years
Discussion Span
Last Post by Serunson
0

Its a 1.6 GHz intel celeron M, 1GB Ram, 80gb hard drive (only a quarter full)
it has a 5200rpm internal drive and i've tried running the games from a 7,200rpm external drive connected via usb.
Its a 128mb video card but its the intel chipset (latest drivers) and just updated the BIOS.
oh yeah and its media center sp2

Hope thats enough for you.

System requirements lab says they should all run fine, and i've tried using the original cd and no-cd patches but still keeps crashing :S

0

thats because its the intel chipset

onboard graphics cards are crap for playing games on because there not real graphics cards. what they do is steal 128mb from your system RAM.

0

invest in a new graphics card!

please check ur motherboard for an AGP or a PCI Express slot, you need a different card for each slot!

0

I know the intel chipset is crap but this was all i could afford for a laptop at the time.

Its strange that i can get games like fable and gun to run smoothly with no problems but not these others. i thought it was a Direct x error but some other games run fine like i said.

Thanks guys :)

0

oh a laptop?

you wont be able to upgrade the graphics card then. youre kinda screwed when it comes to modern games.

0

Best invest in a new laptop, or you can get quite cheap PC's (i.e. a big bulky thing) and upgrade the components, but you of course loose the portability.

0

I know what you mean, i never expected any miracles from it its just strange that it will play some games and not others.
Apparently i'm not the only person having problems with C&C 3 but dont get why the others wont work.
Ah well best to wait until i can upgrade.

Thanks for all the help guys and gals

0

yeah its just recent games

i have a dell desktop. i can play Battlefield 2 , Farcry etc... all ok but not Medevil Total war, Age of empireres 4 etc....

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.