0

I run Win2K Pro, SP4 + all updates
I use a Microsoft Optical Wireless Desktop 700 (wireless keyboard + wireless mouse + shared USB Receiver)
For some time after initial installation, keyboard & mouse both worked perfectly
The keyboard has recently stopped working for no obvious reason
Current situation:
Mouse always works
Keyboard always works in BIOS
Keyboard always works when booting into Linux from CD
Keyboard fails to work when booting into Win2K
New batteries and repositioning Receiver with respect to keyboard bring no improvement
I'm using Win2K default drivers (i.e. no MS Intellitype software, although I've tried loading various versions of this with no improvement)
Device Manager shows all drivers OK (no yellow question marks on any device)
If I plug in wired PS/2 keyboard before Win2K boots, USB keyboard and PS/2 keyboard both work
I suspect a Registry key or driver has become corrupted (but what do I know...)
Has anyone any ideas as to what I could try??

2
Contributors
10
Replies
11
Views
10 Years
Discussion Span
Last Post by AncientBrit
0

Ok i know that in XP you need to go admin tools -> services and enable the Human Interface Device service or something like that. Maybe a similar service exists in windows 2000?

0

First of all, I forgot to include one important fact in my problem description as originally posted: as soon as I unplug and replug the Receiver into any USB port, the keyboard immediately starts working!

Yes, Win2K has a similar system to XP: it's possible to set a service to Automatic, Manual or Disabled. After booting and while the keyboard was still non-functional (with wired PS/2 keyboard not connected and before unplugging & replugging the Receiver to get the USB wireless keyboard to work), I found HID Service to be set to Automatic and to be running.

Also with no PS/2 wired keyboard not connected and USB wireless keyboard not yet working, What's Running (www.whatsrunning.net) reported the following keyboard-related things:
Process: hidserv.exe: running
Module: HID Input Service (HidServ): running
Driver: Keyboard HID Driver (Kbdhid): running
Driver: Keyboard Class Driver (Kbdclass): running
Driver: i8042 Keyboard and PS/2 Mouse Port Driver (i8042prt): stopped

I remain at a loss...

0

(In previous post, I meant to write "no PS/2 wired keyboard connected" not "no PS/2 wired keyboard not connected")

One more possible clue: even when keyboard not working, i.e. having no effect on monitor display, LED on Receiver nevertheless blinks in sync with key presses

0

Yes, wireless USB keyboard works in BIOS but not in Win2K (unless wired PS/2 keyboard plugged in during boot or unless wireless receiver unplugged & replugged).
Possible Win2K bug? This seems unlikely to me since for a good while after installation, the wireless USB keyboard worked at all times.

0

i had a similar bug with linux before, but i never got it solved... tell me, does it work if you leave it for a while (over an hour). also, does it not work at the login screen or the desktop? because i thaught that win2ks security features only loaded minimal services at login time to prevent keyloggers etc...

0

Leaving the PC for over an hour after booting made no difference -- no keyboard until I unplugged & replugged the USB Receiver.
This PC is in my home office and I'm the only user, so I don't bother with a password. Each month Win2K asks me if I want to change the password and I always choose Yes but then enter nothing in the password box. As far as I can recall, I've never been unable to carry out these keyboard actions, but the next time it happens, I'll be alert and report back. If keyboard works as described, but fails when Win2K boots, what does it mean or point to?
Keyboard does not function at the desktop until USB Receiver unplugged & replugged.
Yesterday, I reinstalled all USB and keyboard drivers via Device Manager: no change in situation.
I still suspect a Registry entry is wrongly set. If anybody reading this has Win2K and a USB keyboard on their machine, I'd appreciate a list of all Regedit key settings to do with keyboard & HID USB. I know this is clutching atstraws, but I can't think of any other approach.

0

I'm afraid not! But I don't recall there having been any connection between this problem and just having installed a Microsoft Win2K update...

0

This problem was resolved when the legends on the Microsoft wireless keyboard began to wear away, forcing me to buy new. This time I went for a Logitech wireless keyboard & mouse - and lo and behold, the problem described above magically disappeared.
Microsoft 0, Logitech 1!

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.