When ever I use the search function in windows xp professional with the advanced search options I get a lock up of the search function and I usally get the search folder that does not close. Also I get a data execution prevention error. I have Comodo firewall installed and Node 32 antivirus. If I don't use advanced search options, the program does not lock up. I have scanned for virus with several on line services, there are no virus on the computer. To unlock to computer screen, I must go into windows task manager and the programs that I must stop to unlock the computer are DR. Watson and usally there are more than 1 running at at time. I have tried about everything that I can think of including reinstalling windows which did not help. I am running a MSI K8n Neo 4 with 64xs 4600 AMD processer with 2 g memory. Mem tested the memory OK. New build with new power supply. What would cause this. No new software installed.

If you are unable to use 'Search' Function properly then disable the Advanced options of it. And also tell the name of program which will be blocked by DEP (Data Execution Prevention).

As stated it only froze when using the advanced search portion of the search program and the Program blocked by DEP was Dr. Watson. On the Windows task manager there usually was listed more than 1 Dr. Waston running, some with 0 memory usage and 1 that was using memory. If the Dr. Watson was closed that was using memory, then the computer unfroze. For whatever reason, after looking at different forums, there did seem to be a link with right clicking windows explorer and there was a link to nvidia shell extensions causing some problems very similar. I got a program that displayed shell extenions, and disabled some nvidia shell extensions and the program no longer locks up.

Good..hope your problem has been solved. If till DEP blocks Windows services then you can unblock it through Systems Advanced settings.

To go to DEP section follow this steps:

Right click on My Computer > Properties > Advanced under Performance category select Settings and check for Data Execution Prevention tab, here select Manual Configuration and block or unblock Windows Services.