Hi, I have a network set up at home with 4 computers, file sharing works fine between all of them, i bought a 120g usb2 Maxtor onetouch external hard drive for one of the computers recently and it works as i would like however when i try and share any folders on it so the other computers can get files from it it doesnt work, when someone tries to access it from another pc i get

\\'computer name'\folder is not accessible, you may not have permission to use this netork resource. Contact the administrator of this server to find out if you have access permissions.

the device is not ready.

Is there a solution to this and if so how can it be fixed, ive searched on arious sites but havent found a solution to a similar problem. If someone could help me i'd be most grateful.

Many Thanks-smoiu

Sorry, should have mentioned using a linksys router and all users are on xp home

Hello,

Filesharing requires 4 basic things: Network connectivity, Firewall permissions, NTFS Permissions, and Sharing Permissions. I think your Network and firewall is working properly, so let's look at NTFS and File Sharing.

1) Did you format the new drive? Is it FAT32 or NTFS? If NTFS, did you allow the local users group access to the drive? To test, go to the computer that has the drive attached to it, login as the user, and see if you can create a folder there. If so, permissions are fine. If it is a FAT32 drive, do not worry about this part at all.

2) Did you setup sharing permissions properly? You should right-click on My Computer, and go into Manage. Go into the Shared Folders... and find your share. Check the share permissions to make sure the group/users is enabled properly.

Let us know what you find.

Christian

Hello,

Filesharing requires 4 basic things: Network connectivity, Firewall permissions, NTFS Permissions, and Sharing Permissions. I think your Network and firewall is working properly, so let's look at NTFS and File Sharing.

1) Did you format the new drive? Is it FAT32 or NTFS? If NTFS, did you allow the local users group access to the drive? To test, go to the computer that has the drive attached to it, login as the user, and see if you can create a folder there. If so, permissions are fine. If it is a FAT32 drive, do not worry about this part at all.

The drive is in ntfs, i can use the drive from my computer as i would a normal drive-create and delete folders and files, is this what you meant? If you meant go to the computer from another computer then no i cant create a new folder, as soon as i try and open a shared folder on the drive the error message comes up


2) Did you setup sharing permissions properly? You should right-click on My Computer, and go into Manage. Go into the Shared Folders... and find your share. Check the share permissions to make sure the group/users is enabled properly.

Sorry, im not sure what you mean here, i go to manage and then shared folders and it shows a list of my shared folders with columns saying the path, the type, comments and client connect. The only thing i can seem to do from here is refresh and send console messages, i cant find anything to do with share permissions

Let us know what you find.

Christian

Thanks for your reply

Looking in the help file I dont think access control is available in xp home

Does anyone have an idea of what the problem may be?

I'm facing the same problem. Did you ever succeed in sharing your external hard drive?

I'm facing the same problem. Did you ever succeed in sharing your external hard drive?

Answered my own question. As kc0arf suggests it has to do with permissions of the external hard drive. To set them:

My computer->right click hard drive->properties->sharing & security tab->select "share this folder on the network." Also select "Allow network users to change my files."

Answered my own question. As kc0arf suggests it has to do with permissions of the external hard drive. To set them:

My computer->right click hard drive->properties->sharing & security tab->select "share this folder on the network." Also select "Allow network users to change my files."

___________________________________________________________


My Name is Ray. I have this same exact problem. I can use the External Hard drive at the PC it is connected too but the drive cannot be accessed from any PC on the my Netwrok. Sharing is in place. Infact the same sharing options selected for the external HD is the same sharing option selected on the other drives on all 4 of the other PC's on my network and they all work fine. I am using a LinkSYS WRT54GS router and LinkSYS speedbooster PCI card. I have 4 PC's connected in total. My problem is I cannot access my external hard drive from any PC on my network other than from the PC (My server) the External Hard drive is connected to. All permissions are in place and all drives are shared properly. I can access all of my servers IDE hard drives except my external hard drive. The hard drive is Western Digital Model #:WDXUB2500JBNN. I shared the drive as standard procedures. I can see the drive on all systems but cannot access the drive. All systems are running Windows XP. Im using Nortons Firewall and ZoneAlarm 6. Even if I disable the firewalls still no access. I have searched and searched the net with no real answers. This tread was the closet I've gotten to a similar problem. Hope I was detailed enough to have my question answered. PLEASE HELP ME.

___________________________________________________________


My Name is Ray. I have this same exact problem. I can use the External Hard drive at the PC it is connected too but the drive cannot be accessed from any PC on the my Netwrok. Sharing is in place. Infact the same sharing options selected for the external HD is the same sharing option selected on the other drives on all 4 of the other PC's on my network and they all work fine. I am using a LinkSYS WRT54GS router and LinkSYS speedbooster PCI card. I have 4 PC's connected in total. My problem is I cannot access my external hard drive from any PC on my network other than from the PC (My server) the External Hard drive is connected to. All permissions are in place and all drives are shared properly. I can access all of my servers IDE hard drives except my external hard drive. The hard drive is Western Digital Model #:WDXUB2500JBNN. I shared the drive as standard procedures. I can see the drive on all systems but cannot access the drive. All systems are running Windows XP. Im using Nortons Firewall and ZoneAlarm 6. Even if I disable the firewalls still no access. I have searched and searched the net with no real answers. This tread was the closet I've gotten to a similar problem. Hope I was detailed enough to have my question answered. PLEASE HELP ME.

Sorry but i cant really help, for no noticable reason it just started working, external drive is now just like a normal drive for sharing :confused: as far as i know i didnt change a thing!!

I had met the same case. But with internal HDs, 4 PCs are connected to each other by a hub (A, B, C, D) .However C cannot access to D, but D can access to C. C can see D in network but can access to D, it's called provisional drive. 4 PCs are connected to A (PC server), and A can access to all PC in network, n B is too. I had checked: the same group name, administrator name, FAT 32,... It's like 1-n relationship in MS eccess!:!:

I have the same problem. I have 6 internal hard drives on the same PC and have used the same method to share those hard drives as I have done with the external hard drive.

I can view the root folder of the external hard drive from the network but once I try to access a folder, I get the same error message.

I am using XP MCE and this is completely illogical as to why external hard drives will not share even though the same method has been used to share them as with the internal hard drives. The internal hard drives share perfectly.

I am using a Linksys WRT54GL, 2 PC's + 1 laptop. I couldn't find anything on the Windows support site talking about this problem.

Hi, I have a network set up at home with 4 computers, file sharing works fine between all of them, i bought a 120g usb2 Maxtor onetouch external hard drive for one of the computers recently and it works as i would like however when i try and share any folders on it so the other computers can get files from it it doesnt work, when someone tries to access it from another pc i get

Is there a solution to this and if so how can it be fixed, ive searched on arious sites but havent found a solution to a similar problem. If someone could help me i'd be most grateful.

Many Thanks-smoiu

I had this problem, and after many hours work found the answer at:http://www.pcdoctor-guide.com/wordpress/?p=174

It does require modifying the registry, but it is very stright forward, and it works.

I had this problem, and after many hours work found the answer at:http://www.pcdoctor-guide.com/wordpress/?p=174

It does require modifying the registry, but it is very stright forward, and it works.

I too have this problem, sometimes it works sometimes it doesn't. I have to renew the sharing permissions on the external drive every time it is switched on. Even then it doesn't always work.
I'd like to try the registry fix you direct us to, but it doesn't seem to the same issue - is this reference correct?

Cheers

I've been reading around for methods to share external hard drives, and like Climax510 this has been an informative thread.

What i did:

after i had ran the network setup wizard on both my pc(statinary as primary gateway) and my laptop(which uses a wireless connection through the router), I logged on to the pc as the admin and rightclicked the external drive from My Computer, selected Sharing and Security..., then the properties box that pops up should be on the Sharing tab (I had to click on a blue link that was confirming that i knew the risks of sharing the root of a drive), there should be a "Network sharing and security" section with two checkboxes (check them both) and a box that asks for the "Share name:" Then it prompted me to define a network, this should look like the path to a folder, use the browse feature and find the name of the 'workgroup' you have defined prior(you should have to go through the computer name and possibly the user names on your comupter till you find it, just keep hitting the +icons). Then finish the wizard.

The Drive should now show up in the My Netowrk Places folder from your other computers' Start menu, looks like a normal folder with the name you had selected earlier. However, it does not appear with the other drives from the My Computer folder.

Sorry to double post, but i also found this page while looking for a way to put the external hard drive into my laptops' My Computer drive list.
http://tech.yahoo.com/gd/sharing-a-hard-drive-over-a-home-network/153494

But to actually put the shared hard drive into your My Computer drive list you need to rightclick My Computer and just click the 'Map Network Drive'. Then all you do is select the drive letter, and locate the external drive using Browse(again it should be located in the my network places folder).

I too have this problem, sometimes it works sometimes it doesn't. I have to renew the sharing permissions on the external drive every time it is switched on. Even then it doesn't always work.
I'd like to try the registry fix you direct us to, but it doesn't seem to the same issue - is this reference correct?

Cheers

YES!!!! I tried the registry fix and it has been miraculous. I wondered if it would help on the laptop as well as the desktop with external HD. Anyone got any views on this?

I have found that occasionally I need to reset the sharing permissions on the external drive. I haven't had to do that since I set it's drive letter permanently as E. Occasionally the PC would set it with F, when I used another USB external such as digital camera or Ipod.

I right clicked on the external hard drive letter and "map network drive".
Under "Security" I clicked "advanced settings" and "add" (user). I added "everyone" and set the permissions to "full control".
This worked.

Answered my own question. As kc0arf suggests it has to do with permissions of the external hard drive. To set them:

My computer->right click hard drive->properties->sharing & security tab->select "share this folder on the network." Also select "Allow network users to change my files."

That was me sorted. Why oh why do you have to set permissions in the "Sharing" tab AND in the "Security" tab of the HDD's properties?** Hopefully I'll not forget that next time.

My prob was new router but no other changes - two of my 3 PC's (one each of XP vista and Win7) have external drives which I wanted to network but couldn't - until this fix - for which I am ever grateful. What I did was add "everyone" as a user and set their various permissions as "allowed" for all actions - result both HDD's are seeable and changeable - and now useable for backups. Joy!!

** why is the sky blue? Why can't you trust politicians?

Edited 6 Years Ago by PedroStephano: additional info

Hi all,
I faced the same problem and solved the problem by googling around and after I this page:
http://support.microsoft.com/default.aspx?scid=kb;en-us;177078

Follow the below instruction and restart computer.

1. Click Start, and then click Run.
2. Type regedit, and then click OK.
3. Navigate to the following key:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanmanServer\Parameters
4. In the right pane, double-click the IRPStackSize value.
NOTE: If the IRPStackSize value does not already exist, use the following procedure to create it:
a) In the Parameters folder of the registry, right-click the right pane.
b) Point to New, and then click DWord Value.
c) Type IRPStackSize.

IMPORTANT: Type "IRPStackSize" exactly as it is displayed because the value name is case-sensitive.
5. Change the Base to decimal.
6. In the Value Data box, type a value that is larger than the value that is listed.

If you created the IRPStackSize value using the procedure described in step 4, the default value is 15. It is recommended that you increase the value by 3. Therefore, if the previous value was 11, type 14, and then click OK.
7. Close the Registry Editor.
8. Restart the computer.

Actually for me the solution worked only after changed the decimal value to 21.
good luck guys.

This article has been dead for over six months. Start a new discussion instead.