0

Hi All,

I posted this in the Windows XP forum, but no one offered any help. I figured that I would post it in the Networking section to see if anyone here had any ideas. Thanks!


I have read this site often, but this is my first post. I have a weird problem with my new wireless network. I am running an HP Pavillion laptop with XP SP2. The router I am using is a Linksys WRT54G.

I have two laptops in the house (one Mac and the PC). The Mac sees the network fine and can browse without problem. The PC says that it is connected to the wireless network, but it will not browse. No programs that need access to the internet work either. Sometimes I can ping the router when I am "connected" wirelessly but not consistently. I cannot ping any external IP addresses.

I have all ready tried the TCP/IP and winsock2 refreshes.

The really weird thing is that I can connect to other wireless networks in the area and browse them without problem. Also, if i wire directly into the router I do not have a problem.

I spent 2 hours on the phone with a guy from Linksys today to no avail. He said that he thought it might have something to do with the fact that I just moved into a high-rise apartment building, so there are a lot of wireless networks in the area.

Any help that anyone can offer would be great!

-garth

4
Contributors
58
Replies
59
Views
9 Years
Discussion Span
Last Post by garthparties
Featured Replies
  • 1

    Good luck...before re-formatting, I would give the folks at the Virus, Spyware, etc. forum under Windows a chance to help you fix it first. There are some tools listed there under the sticky posts that make it pretty easy to straighten out any software issues. Read More

0

Could you go to command line when you are connected to the wireless and run ipconfig /all
and post the results here.

0

I ran the ipconfig/all. I ran it when I was attached to my neighbor's unencrypted network and my own (not working) network. The results were the same for each. I presume this fact does not bode well for fixing the problem...

Anyway, here are the results:

Windows IP Configuration:
Host Name..................................:brad-ad2e43e01b
Primary Dns Suffix.......................:
Node Type..................................:Hybrid
IP Routing Enabled......................:No
WINS Proxy Enabled...................:No
DNS Suffix Search List.................:hsd1.ma.comcast.net.

Ethernet adapter Wireless Network Connection:
Connection Specific CNS Suffix......:hsd1.ma.comcast.net.
Description..................................:Intel (R) PRO/Wireless 2200BG Network Connection
Physical Address..........................:00-0E-35-39-88-39
Dhcp Enabled...............................:Yes
Autoonfiguration Enabled...............:Yes
IP Address...................................:192.168.1.122
Subnet Mask.................................:255.255.255.0
Default Gateway............................:192.168.1.1
DHCP Server.................................:192.168.1.1
DNS Servers.................................:68.87.71.226
68.87.73.242
68.87.64.146
Lease Obtained..............................:Tuesday, August 19, 2008 7:50:47PM
Lease Expires................................:Wednesday, August 20, 2008 7:50:47PM

Ethernet adapter Local Area Connection:
Media State..................................:Media Disabled
Description...................................:Realtek RTL 8139 Family PCI Fast Ethernet NIC
Physical Address...........................:00-0F-B0-03-5D-F4

0

For one thing, you've got a media disabled message re: your ethernet adapter on this connection. Can you check that first?

I'd like to see an ipconfig /all from both connections.

0

Isn't the media disable message message for the wired connection?

I am at work now. I will rerun the two different ipconfig/all when I get home.

0

Yes but it means you've got the wired connection enabled alongside the wireless. While testing wireless, you might want to disable the wired connection just for elimination purposes, AFTER running the two ipconfig /all so you won't change anything in the reports you post before we get to see them.

0

Unfortunately, I didn't have time to run the ipconfig/all functions tonight. I will do it tomorrow. Thanks to everyone who has offered help so far!

0

Open control panel, click on Network Connections, right click on you wireless connection and click properties. Click on Internet Protocol (TCP/IP) once to highlight it and click properties. Make sure you are set to Obtain an IP address automatically, and Obtain DNS server address automatically.

This will verify that DHCP is enabled. I know your post of the original ipconfig /all listed it as enabled, but I don't see how you would get the same IP address different routers.

0

Here are the ipconfig/all results when I am connected to my neighbor's wireless network:

Windows IP Configuration

Host Name . . . . . . . . . . . . : brad-ad2e43e01b
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No
DNS Suffix Search List. . . . . . : hsd1.ma.comcast.net.

Ethernet adapter Wireless Network Connection:

Connection-specific DNS Suffix . : hsd1.ma.comcast.net.
Description . . . . . . . . . . . : Intel(R) PRO/Wireless 2200BG Network
Connection
Physical Address. . . . . . . . . : 00-0E-35-39-88-39
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IP Address. . . . . . . . . . . . : 192.168.1.122
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.1.1
DHCP Server . . . . . . . . . . . : 192.168.1.1
DNS Servers . . . . . . . . . . . : 68.87.71.226
68.87.73.242
68.87.64.146
Lease Obtained. . . . . . . . . . : Thursday, August 21, 2008 11:47:01 A
M
Lease Expires . . . . . . . . . . : Friday, August 22, 2008 11:47:01 AM

0

Here are the results of the ipconfig/all when I am "connected" to my own network. The IP address is still the same even though I have it set to autoconfigure. Also, I turned of the wired connection to avoid any confusion.


Windows IP Configuration

Host Name . . . . . . . . . . . . : brad-ad2e43e01b
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No
DNS Suffix Search List. . . . . . : hsd1.ma.comcast.net.

Ethernet adapter Wireless Network Connection:

Connection-specific DNS Suffix . : hsd1.ma.comcast.net.
Description . . . . . . . . . . . : Intel(R) PRO/Wireless 2200BG Network
Connection
Physical Address. . . . . . . . . : 00-0E-35-39-88-39
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IP Address. . . . . . . . . . . . : 192.168.1.122
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.1.1
DHCP Server . . . . . . . . . . . : 192.168.1.1
DNS Servers . . . . . . . . . . . : 68.87.71.226
68.87.73.242
68.87.64.146
Lease Obtained. . . . . . . . . . : Thursday, August 21, 2008 9:08:59 PM

Lease Expires . . . . . . . . . . : Friday, August 22, 2008 9:08:59 PM

0

OK, there's a couple of things going on here. Are you connecting to your neighbors network from your house, or are you going over there? If you're going over there, can you maintain a connection all the way back to your place?

Can you get your neighbor to turn of his router while you test yours?

0

Hi zeroth,

I am connecting to my neighbor's network from my apartment. I just moved into a large apartment building in downtown Boston, so there are a lot of wireless networks in the area. I do not even know who this network belongs to. I just hooked into it to test my computer's wireless ability. I cannot ask the owner to turn it off, because I don't know who the owner is. Sorry.

0

I think I've narrowed down the problem but let's try a few things. First, I don't think you're connected to your router at all. What ISP do you use?

Take a look at all the wireless networks you can see from your computer - what name is your router broadcasting? On your wireless connection, do you have TCP/IP set to Obtain IP Address Automatically, and the same with Obtain DNS servers automatically.

After these checks on your ethernet settings, can you sign onto your router and check a few things, like have you got DHCP enabled? If you need instructions, just ask.

If we find what I believe we'll find, it's a router issue...in any case, it's probably just a simple fix once we locate it.

0

I use Comcast. The modem is getting a signal. When I wire directly into the modem of the router I am able to access the internet.

Our network's name is Brevra. I can see it an 9 others from my computer.

TCP/IP and DNS are set to obtain automatically. DHCP is also set to automatic.

Thanks for the help.

0

Let's check to see if you are really connecting to your router and not someone else's. First, connect to the router by cable and disable your wireless connection. Then go to the setup page in your Linksys router and change the Starting IP Address to 192.168.1.200. Then the Maximum Number of DCHP Users, you can just change to 10 or something small.

That will give you a pool of possible IP addresses that the router can hand out. From 192.168.1.200 to 192.168.1.209

When you sign on wirelessly, check for wireless networks near you first and choose your router and then you should have an IP in the above range. If you don't, you're signed on to a neighbor's network and not yours.

0

Hi zeroth,

I performed the check that you recommended. I changed the router's Starting IP Address to 192.168.1.200 and limited the number of users to 10. Here are the results fromt he ipconfig/all with the new settings:

Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\Brad>ipconfig/all

Windows IP Configuration

Host Name . . . . . . . . . . . . : brad-ad2e43e01b
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No
DNS Suffix Search List. . . . . . : hsd1.ma.comcast.net.

Ethernet adapter Local Area Connection:

Media State . . . . . . . . . . . : Media disconnected
Description . . . . . . . . . . . : Realtek RTL8139 Family PCI Fast Ethe
rnet NIC
Physical Address. . . . . . . . . : 00-0F-B0-03-5D-F4

Ethernet adapter Wireless Network Connection:

Connection-specific DNS Suffix . : hsd1.ma.comcast.net.
Description . . . . . . . . . . . : Intel(R) PRO/Wireless 2200BG Network
Connection
Physical Address. . . . . . . . . : 00-0E-35-39-88-39
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IP Address. . . . . . . . . . . . : 192.168.1.122
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.1.1
DHCP Server . . . . . . . . . . . : 192.168.1.1
DNS Servers . . . . . . . . . . . : 68.87.71.226
68.87.73.242
68.87.64.146
Lease Obtained. . . . . . . . . . : Sunday, August 24, 2008 11:46:22 AM
Lease Expires . . . . . . . . . . : Monday, August 25, 2008 11:46:22 AM


Windows IP Configuration

Host Name . . . . . . . . . . . . : brad-ad2e43e01b
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No
DNS Suffix Search List. . . . . . : hsd1.ma.comcast.net.

Ethernet adapter Local Area Connection:

Media State . . . . . . . . . . . : Media disconnected
Description . . . . . . . . . . . : Realtek RTL8139 Family PCI Fast Ethe
rnet NIC
Physical Address. . . . . . . . . : 00-0F-B0-03-5D-F4

Ethernet adapter Wireless Network Connection:

Connection-specific DNS Suffix . : hsd1.ma.comcast.net.
Description . . . . . . . . . . . : Intel(R) PRO/Wireless 2200BG Network
Connection
Physical Address. . . . . . . . . : 00-0E-35-39-88-39
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IP Address. . . . . . . . . . . . : 192.168.1.200
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.1.1
DHCP Server . . . . . . . . . . . : 192.168.1.1
DNS Servers . . . . . . . . . . . : 192.168.1.1
Lease Obtained. . . . . . . . . . : Sunday, August 24, 2008 11:53:24 AM
Lease Expires . . . . . . . . . . : Monday, August 25, 2008 11:53:24 AM

0

I'm sorry. I accidentally posted two there. The ipconfig/all results that came from being attached to the network with the changes you recomended are these:


Windows IP Configuration

Host Name . . . . . . . . . . . . : brad-ad2e43e01b
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No
DNS Suffix Search List. . . . . . : hsd1.ma.comcast.net.

Ethernet adapter Local Area Connection:

Media State . . . . . . . . . . . : Media disconnected
Description . . . . . . . . . . . : Realtek RTL8139 Family PCI Fast Ethe
rnet NIC
Physical Address. . . . . . . . . : 00-0F-B0-03-5D-F4

Ethernet adapter Wireless Network Connection:

Connection-specific DNS Suffix . : hsd1.ma.comcast.net.
Description . . . . . . . . . . . : Intel(R) PRO/Wireless 2200BG Network
Connection
Physical Address. . . . . . . . . : 00-0E-35-39-88-39
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IP Address. . . . . . . . . . . . : 192.168.1.200
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.1.1
DHCP Server . . . . . . . . . . . : 192.168.1.1
DNS Servers . . . . . . . . . . . : 192.168.1.1
Lease Obtained. . . . . . . . . . : Sunday, August 24, 2008 11:53:24 AM
Lease Expires . . . . . . . . . . : Monday, August 25, 2008 11:53:24 AM

0

OK, you are now definitely connected to your router...can you browse? I'm concerned about your DNS server...

If you still can't browse...power down the router and let it come up clean again and make sure you get the same IP address and see if you can browse.

0

Sorry, you should power down both the modem and the router and bring them up again modem first if you aren't able to browse. In any case, if everything is set up correctly, that should not cause any problems to reboot everything.

btw, you didn't mention if you have any security set up on the router.

0

I performed a power cycle on the modem, router, and computer. The IP address was the same before and after the power cycle. I still cannot browse. What I really don't understand is that the other laptop in the apartment can connect perfectly well.

Btw, I have WPA security set up on the router.

0

have you checked the IP address on the other machine? Can you ping from machine to machine?

When you go to your router maintenance screen, can you check the Status tab, then Local Network, then DHCP client table. What do you see there?

One other place you can check - right click on My Computer and choose properties, then Computer Name. Check the Full computer name and the Workgroup name. Make sure these are the same on both computers. You can go thru the Join a doman process thru the Change button, it won't hurt anything. I'm just trying to think of everything that might be the problem.

While you're at it, you can see if, after both IPs are OK, the two computers can see each other. Just left click My Network Places and see if you can go through the path to the other computer.

0

The IP Adresses for both machines are 192.168.1.200 and 192.168.1.201. When I ping from the laptop that works to the one that does not it loses 80% or 90% of the packets. When I ping from the computer that isn't working to the one that is, 75% (or so) of the packets get lost.

The DHCP Client Table lists both of the computers and their IP Adresses.

I can access the full computer name and workgroup name for my PC, but the other computer (a Mac) did not have a workgroup name listed. Also, should the computer's have the same full name or just workgroup name?

I couldn't get to the other computer thru My Network Places. I don't know if this problem has to do with the fact that one is a Mac and the other (not working) one is a PC.

0

The IP Adresses for both machines are 192.168.1.200 and 192.168.1.201. When I ping from the laptop that works to the one that does not it loses 80% or 90% of the packets. When I ping from the computer that isn't working to the one that is, 75% (or so) of the packets get lost.

Well, that's not good...lol

The DHCP Client Table lists both of the computers and their IP Adresses.

Good, at least we've established that you're connected to your router and it sees both the Mac and the PC. Just to eliminate any issues there, you might disconnect the Mac and try to see what happens...I doubt anything will but you never know.

I can access the full computer name and workgroup name for my PC, but the other computer (a Mac) did not have a workgroup name listed. Also, should the computer's have the same full name or just workgroup name?

The computers should have different names but the workgroup name should be the same. The Mac not having a workgroup is of concern if we're trying to talk between the computers but would not affect the ability of the PC to browse.

I couldn't get to the other computer thru My Network Places. I don't know if this problem has to do with the fact that one is a Mac and the other (not working) one is a PC.

That is something I can't help you with (if I can help you at all...lol) because I know nothing about Macs. Can you at least see the other computer is there, i.e., pick up the other computer's name?

Let's look at this as two problems, 1)getting the PC to browse and 2) get the computers communicating. If you disconnect the Mac and the PC still does not browse, you can try this:

Your ipconfig report shows the router's IP 192.168.1.1 as the DNS Server. I think that's OK but let's try something. You can google Comcast DNS server addresses - the national Primary DNS Server is 68.87.66.196 and secondary is 68.87.64.196 - you should do the search yourself and choose the nearest geographically. Try putting that in Internet Protocol (TCP/IP) Properties instead of the auto setting you have now. It's worth a shot.

Every time we eliminate a possible problem causer we get closer to the real issue. I'd bet it's something simple at this point. Maybe someone else can see something we've overlooked...

btw, what channel is your router transmitting on? You could be getting interference from the other guy's router. Also, did you try running the network setup wizard on the PC?

0

Thanks for all the help zeroth. Right now, my major concern is getting the PC to browse. I don't really care about getting the computers to communicate.

I changed the DNS server to 68.87.96.3 and 68.87.96.4.

The router is set to broadcast on channel 9.

0

Thanks for all the help zeroth.

Yeah, well I don't think I've helped a whole lot even after all those emails. We did eliminate a lot of things. I'm assuming these last changes didn't help and you still can't browse.

Is the Mac still connected...able to browse with these new DNS addresses? And the channel change?

One more idea...you can try to turn off the encryption on both card and router and try it again. I'm kind of surprised we haven't had some other ideas from all the others following this thread.

zeroth

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.