0

Ok, I'm a pretty tech savvy guy. I've spent enough time around computers to have at least picked up the intermediates, if not most of the advanced stuff.

Here's the setup I have goin on. Linksys BEF router and like a 10 port Linksys Hub. Some sort of crappy DSL modem, but it does the job.

I'm not gonna worry about throwing out exact model numbers and the like because I've narrowed down the issue to the point where that crap does not matter any more.

Ok, the issue is definitely a mixture of problems between the router and one of the computers on our network. The computer in question has an ASUS A7N8X-E (Deluxe) mobo. This mobo has two onboard NIC's. One is an nVidia, and the other is a Marvell Yukon.

Recently I started connecting this computer to the Linksys router. During the day I have to disconnect the computer from the network (it is only connected to the network from around 6pm - 3 AM), and generally only on weekdays.

At first I was using the nVidia NIC as it is the one intended to be used for Internet access (according to Asus). I play Unreal Tournament and WoW. I started having major issues with my connection on the first day.

Firmware = upgraded.
Resets = a million times. Cycling whole nine yards, etc, etc.

Problems occur one of two ways-

1.) Lesser Of Two Evils: I'll lose connection, but then it will pop back on 2 minutes later. All computers on the network drop connection at same time. It will stay connected for ~10-15 minutes, and then the problem repeats.

2.) THE HUGE MEGA EVIL of EVILS: Ok, this sh** blows my mind.
I'll lose connection.
Connection does not come back. Only way to get it back is a complete power cycle.

Now for the information that might help you help me:

Ok, so I was using the nVidia NIC like I said... but the problem started repeating every 2-3 minutes after a while. Like literally the connections started dropping for the entire network faster and faster. Finally, I narrowed the issues down to my NIC, and I just stopped using it (resorting to the Marvell).

No issues with Marvell Gigabyte NIC for at least a week, then all of a sudden it starts dropping. Can't get connect back. Tried releasing DHCP, everything, get no results. (power cycle will work, but I'm not gonne do this every 1- minutes till eternity).

Anyway, when I go into my router and check settings (during an outage), I see several important pts of information:
1.) No "Time of Day" shown from cable modem (Not Available) instead.. so my router has dropped the connection? (You would think, but I'm not entirely convinced.
2.) Expired Client Lease Times and / or missing clients on the DHCP list (and when I mean expired, I mean it sets the expiration date at 2003).

Trying to fix problem #2 is like hell on earth... Client Lease Time was set to (0) - default - means one day. I recently changed it to 9999 (heard this helps, but not from experts). I wanna know why its bugging out in the first place.

I've talked to Linksys - they're all about firmware and power cycling, and as much fun as those two things are, I've got better things to do than power cycle 100x / day.

I have connected directly to DSL modem and never had issues (even during times when router is "dropping" connection or corrupting the network info). The DSL modem does not drop connection (according to lights).

I have a static IP address.

Another issue I've thought might be causing my issue is lag updating the DNS? Maybe the router is just dumb?

Anyway, so that's one issue ^^ All of that is one issue... but the main question I want answered is "why is my computer's client lease time being set to 2003?", and why/how is this possible? Course I just had a thought. I bet the router is just about 3 years old.. so maybe the default exp date is Jan 6 , 2003 or whatever... that would explain the date, but not why it happened in the first place, HELP!?

Other big issue (and possibly related). The biggest reason I stopped using the nVidia NIC on the network was that it's MAC addy got set to 00-00-00-00-.... all 0's... wtf? why? corrupted bad NIC? Router caused it? Virus? Anyway, it still actually works with this addy but not very well =) ie - the connection resets every couple mins (sometimes longer than 10 mins - sometimes less than 5 mins to drop connection).

No idea why. Havent found a thourough description of this kind of issue anywhere as of yet. Still searching. Anyway, I hope someone out there knows what I'm talking about, even if the post is so long and jumbled it would take a phrase-skipper to understand it. Pls ignore all my excess storyline but the semantics seem fairly important to me on this problem.

Honestly I'm trying to find out if my computer and its two onboard NIC's are the problem or if the router is the problem.

I will say that there have never been very good working drivers for my NIC's under win2k professional OS (which I use).

I'm about to go to WinXP Professional and see how the drivers work for those NIC's there, but I'm pretty sure the issues will be the same..

ANy love will be <3'ed 2teh3nd.

:twisted: :twisted: :twisted:

2
Contributors
6
Replies
7
Views
11 Years
Discussion Span
Last Post by hollystyles
0

Phew that's quite a story. Ok you have a static ip from your ISP? that makes you a bit more of a target perhaps. You mention virus towards the end have you done a full scan for viruses *and* anti-spyware scan yet? That's always a good start. The fact you mention it brings down the whole network, means either router problem or NIC problem, if network is fine when nVidia is off the network suggest NIC might be fried (might be braodcasting too much or something) Or driver is corrupt or maybe winsock on that machine is corrupt. Fact that both nVIDIA and now Marvell NIC cause same issue then leads me to think virus or spyware bunging up the network or winsock is stuffed, have you tried the re-installing TCP/IP for example. See here:

http://support.microsoft.com/default.aspx?scid=kb;en-us;285034

The client lease thing is strange, personally I statically address all my PC's at home. DHCP was designed for large networks. If you got 10 machines or less you don't really need it. Besides it's safer from a wireless point of view too, last thing you want is your wireless router dishing out IP's left and right (yes I know you can set MAC address filtering, but MAC addresses can be spoofed) which is the other strange thing. Where are you reading that MAC address 00-00-00-00-00-00 from? are you using ipconfig/all at the command prompt on the machine with the marvell and nVidia NIC's ? or are you reading that from your router?

Hmm if you plug the PC directly into the cable modem you have no problems at all? for sure ? that negates most of the above and points back at the router.

Ok not enough information.

1. How many machines in the network ?
2. What's the DHCP range you're using.
3. Double check all machines' IP configs are set for DHCP (one static address overlapping with lease range and you get behaviour as described)
4. Are they all windows or mixture?
5. Does the Lynksys hub have a switch for Full/Half duplex ? has that got flipped by accident?
6. If you uplink the hub from the router you do know you can't use the port next to the one you've plugged the uplink into.

Actually that's an idea :

1. start with cable modem, factory reset router and one PC, double check everything NO hub yet.
2. Add another PC etc..

Keep going till you hit the snag. The hub is another prime suspect for me.

0

Wow, awesome response. You've given me about 5 more things to cycle through and check, particularly the hub thing. I'm gonna work on this tonight and see how it goes.

about 8-10 computers on network.

the router is wireless enabled.

there are 1-2 other wireless networks fairly close by.. from other businesses.

the router is configured for 50 users I think (DHCP) so a range of 192.168.15.101 - *.*.*.150 or something like that.

I recently did a force change on my NIC nvidia Mac addy - I was viewing its MAC as 00-00*** on both the router and at CMD ipconfig / all.

they are all windows machines (95, 98, 2k prof, and xp machines lol) - occasionally a mac will log on wireless.

my hub:
http://www.jr.com/JRProductPage.process?Product_Id=1197745&JRSource=googlebase.datafeed.LKS+EZXS16W

I did not know (7) - that is very useful information - can't check it right this second to see if it is hooked up that way.

While I'm working on getting this all worked out, got any other ideas about how my MAC addy could have been set to 00-00*** - I've been reading up on spoofing... but only AFTER it happened lol so.. I know I didn't do it personally.

Thanks a lot already.

0

One quick question cause I got a little confused by #7

Is it the router or the hub on which I cannot connect another cable into after uplinking from router to hub?

The router has 4 ports - I use 1-3, and connect to the hub which has 16 ports, which between printers and computers has about 10 connections on it.

Is it on the router that I need to skip a slot? Or the hub?

Currently its set up with router using 1-3, with one of them going to uplink on hub (port 16), there is nothing connected to 15.

0

there are 1-2 other wireless networks fairly close by.. from other businesses.

Whoop Whooop whoop dive dive dive.... I know for example XP wireless config will attempt to leap onto the strongest signal or first one it detects, are you getting a lease from someone elses network. Can you be certain neither of the other two networks are using 192.168.15.*** mask 255.255.255.0 ?
if so move to 192.168.16.*** or 17 etc...

Is it on the router that I need to skip a slot? Or the hub?

The hub.

about 8-10 computers on network.

My router has a limit to how many clients it will dish out IP's to, no matter how many addresses it has spare in thje DHCP range, could that be your problem?

0

Find your nic in the device manager, choose advanced and select locally administered address or something similar. It's possible your MAC has been programmed to all 0's accidentally.


Put it back, the MAC will be printed on the NIC itself somewhere, if its a lappy it will be on the underneath or rear possibly.

0

Wow, awesome response

Thanx. That's ok.

You can click that little link that says "Add to hollystyles's Reputation" on any of one of my posts, if you genuinely feel that I helped your situation at all.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.