0

I currently have one Cisco 1200 AP configured for three SSIDs, each in
its on vlan.
Let SSID1 have vlan1
Let SSID2 have vlan2
Let SSID3 have vlan3

The Cisco 2600 Router is connected to fastethernet port 0/1. The DHCP Server to fastethernet 0/2 and the AP to fastethernet 0/3 of the switch.
Currently if the STA is associated to SSID1, it gets an ipaddress from Scope1 of the DHCP Server. But if the STA is associated to SSID2, it does not get an ipaddress from the scope2 of the DHCP Server. Same is the case for SSID3.

What am I doing wrong? Apparently I have not set the vlan settings on the switch and router appropriately.
Following is my test setup information. Ports 1-4 on the Cisco switch are set up for vlan1.
Ports 5&6 are for vlan2.

Microsoft Windows 2003 DHCP Server
----------------------------------
Scope1 192.168.1.x
Scope2 192.168.2.x
Scope3 192.168.3.x

Single Ethernet card.
No other vlan settings.

Router 2600
-----------
Building configuration...

Current configuration : 1211 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$Fvhb$89r3dU5PJFScD9yj195W/.
enable password aaaaaa
!
no network-clock-participate slot 1
no network-clock-participate wic 0
no aaa new-model
ip subnet-zero
no ip routing
no ip cef
!
!
!
no ftp-server write-enable
!
!
!
!
interface FastEthernet0/0
no ip address
no ip route-cache
speed auto
full-duplex
no mop enabled
!
interface FastEthernet0/0.1
encapsulation dot1Q 1 native
ip address 192.168.1.8 255.255.255.0
ip helper-address 192.168.1.2
no ip route-cache
!
interface FastEthernet0/0.2
encapsulation dot1Q 2
ip address 192.168.2.8 255.255.255.0
ip helper-address 192.168.1.2
no ip route-cache
!
interface FastEthernet0/0.3
encapsulation dot1Q 3
ip address 192.168.3.8 255.255.255.0
ip helper-address 192.168.1.2
no ip route-cache
!
interface FastEthernet0/1
no ip address
no ip route-cache
shutdown
duplex auto
speed auto
!
ip classless
ip http server
!
snmp-server community 2600 RO
snmp-server enable traps tty
!
line con 0
line aux 0
line vty 0 4
password safdf
login
!
!
!
end

Switch 3550
-----------
Building configuration...

Current configuration : 2752 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Switch3550
!
enable secret 5 $1$K1QW$s3Y8bSLDsU1YgfnpidgU9/
!
ip subnet-zero
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
!
!
!
!
interface FastEthernet0/1
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface FastEthernet0/2
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface FastEthernet0/3
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface FastEthernet0/4
switchport trunk encapsulation dot1q
switchport mode dynamic desirable
!
interface FastEthernet0/5
switchport access vlan 2
switchport trunk encapsulation dot1q
switchport mode dynamic desirable
!
interface FastEthernet0/6
switchport access vlan 2
switchport access vlan 2
switchport trunk encapsulation dot1q
switchport mode dynamic desirable
!
interface FastEthernet0/7
switchport mode dynamic desirable
!
interface FastEthernet0/8
switchport mode dynamic desirable
!
interface FastEthernet0/9
switchport mode dynamic desirable
!
interface FastEthernet0/10
switchport mode dynamic desirable
!
interface FastEthernet0/11
switchport mode dynamic desirable
!
interface FastEthernet0/12
switchport mode dynamic desirable
!
interface FastEthernet0/13
switchport mode dynamic desirable
!
interface FastEthernet0/14
switchport mode dynamic desirable
!
interface FastEthernet0/15
switchport mode dynamic desirable
!
interface FastEthernet0/16
switchport mode dynamic desirable
!
interface FastEthernet0/17
switchport mode dynamic desirable
!
interface FastEthernet0/18
switchport mode dynamic desirable
!
interface FastEthernet0/19
switchport mode dynamic desirable
!
interface FastEthernet0/20
switchport mode dynamic desirable
!
interface FastEthernet0/21
nterface FastEthernet0/21
switchport mode dynamic desirable
!
interface FastEthernet0/22
switchport mode dynamic desirable
!
interface FastEthernet0/23
switchport mode dynamic desirable
!
interface FastEthernet0/24
switchport mode dynamic desirable
!
interface GigabitEthernet0/1
switchport mode dynamic desirable
!
interface GigabitEthernet0/2
switchport mode dynamic desirable
!
interface Vlan1
ip address 192.168.1.7 255.255.255.0
no ip route-cache
no ip mroute-cache
!
interface Vlan2
no ip address
no ip route-cache
no ip mroute-cache
shutdown
!
interface Vlan3
no ip address
no ip route-cache
no ip mroute-cache
shutdown
!
ip default-gateway 192.168.1.8
ip classless
ip http server
!
snmp-server community 3550 RO
snmp-server community 3550RW RW
snmp-server location sd
snmp-server contact sd
!
line con 0
exec-timeout 0 0
line vty 0 4
password asdsafd
login
line vty 5 15
password XZCZV
login
!
!
end

2
Contributors
1
Reply
2
Views
12 Years
Discussion Span
Last Post by w1r3sp33d
This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.