Hi all,

I got this new router TP-LINK MR3020 which I has 3 modes it can run in - 3G (for use with modems), WISP and Access Point. When I log in to the router for the first time (through the default IP address of the router), everything goes fine. But as soon as I complete the quick Setup (set SSID and security) and the router reboots, the connection is lost (expected) and when it reconnects, it either does not connect or has limited connection.

The internet works well with the direct wired connection. But through the wireless connection (if at all established), it says the proxy server is refusing connections.

On pinging the router (when the connection does get established),

PING 192.168.0.154 (192.168.0.154) 56(84) bytes of data.
From 192.168.0.101 icmp_seq=1 Destination Host Unreachable

I tried using the router on a friend's laptop (same model, only difference is in the OS; I run Windows 8 and Ubuntu and he uses Windows 7) and it worked ridiculously easily.

Please help! I need the wifi for all my devices. Thanks!

I havent had much time with Windows 8 yet, so my first thought is for you to look at the Windows firewall settings.

Normally, the Destination Host Unreachable (pre Vista) meant that there was no route information in the computer's local routing table. Since Vista, this error message simple means that no ICMP packets returned from the target.

Since you were able to get this to work with another OS, I would look at the Win 8 firewall settings to make sure that you are not blocking outbound and/or inbound ICMP packets.

Is this computer a dual boot system? Where you able to PING it from Ubuntu?

ok! very simple. uninstall window 8 and install window 7.