0

I have two networks at my business. One is a is a network that we use for inventory and inter-office messaging. This network is on the 10.10.x.x ip range.

In my personal office, I have the only computer that is hooked up to the internet. I have a WRT54GS Linksys router hooked up to my cable modem. I have a static ip of 192.168.1.10/255.255.255.0/192.168.1.1 on my desktop.

I wish desperately to share files/printers etc with the 10.10.x.x network. I have a computer on this network on my office that is on this network via an ethernet cable. I added a USB wireless-G adapter to it which connected to my Linksys router (and 192.168.1.x network) and attempted to share files this way. It did not work.

I would imagine there is a way for this to work, if anyone could tell me how I can share files across these networks, it would be a huge help.

2
Contributors
1
Reply
2
Views
10 Years
Discussion Span
Last Post by matt.sherif
0

Okay, I see the issue here, you are using a home router, linksys makes a good router, one of the flaws though is that it only had two interfaces, one for the internet, and the other for the 4 or 8 port switch on it.

routers separate networks, and with the linksys router, that switch and all the ports that are on it, are on the same network, so your computer that is on the router now connecting to the internet has a 192.168.x.x address, thats fine, problem is when we went to hook the 10.10.x.x to the router, these two are not going to talk, because the router is going to look at that and say this shouldnt be on my network, and disregards it.

okay now what we can do to fix this:

Option 1:

we can change the switch interface on the router to a 10.10.x.x network, and hook that to your office stuff, and hook the router and the one computer with internet access to a basic 4 port switch, and hook the switch to the cable modem.


Option 2:

Get another router, configure it to the 10.10.x.x network, and then plug the internet port of that router into one of the switch ports of the original router, this should function without a hitch.


any furhter questions, please feel free to ask.

Matt

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.