0

I have a ASUS A8n-sli premium one with heat pipe....I had just the board in my hands nothing eles and it made a fast pace clicking sound.......HOW??????Not that ot bothers me more that i want to know HOW and WHY.Any hidden fans or something

3
Contributors
10
Replies
11
Views
9 Years
Discussion Span
Last Post by madoverclocker
0

please tell me you grounded yourself before touching electrosensitive components like the motherboard, if not that noise may well have ben static, and you may have killed your motherboard

0

Hmm never thought of stactic. My board is working and it didnt get shocked when i installed it. Odd thing is when i pushed the pci Xpress lever the noise stoped

0

it takes 20,000 volts of static electricity before you will feel or see a shock, but it only takes 3 volts to destroy a mobo. you are very lucky the mobo is still working.

0

It works but i get random lock ups. Doubt it is my mobo tho. I also getartifacts.

0

artifacts means bad graphics card (if its built in then motherboard) usually due to heat or static, can be permanent sometimes

0

hmmmmmm...Is it possible i have alot of static in my pc...never heard of this before.
J/w because i hear glitches in my sound due to static

0

no, your pc is grounded

it is possible for you to have shocked the graphics card with your static when installing it, that will have caused the problem. or maybe you need a driver update.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.