0

My Toshiba l20 starts immediately i plug in the charger and nothing come on the screen also all the indicator lights( I mean the power, charging, HDD lights) will still be off. in this state i can still switch it on and off with the power bottom.

3
Contributors
8
Replies
9
Views
9 Years
Discussion Span
Last Post by jermaghs07
0

wait... im confused. do you turn it on with out it being plugged in? and once you plug it in then the screen and lights shut off?

0

now the battery has run out so without the adaptor it cant be turned on. immediately i plug in the power adapor the fan will start (without touchin any buttom) no light will come including the screen.

at this state i can eject the ccdrom(which means there is power in the cdrom) put the pc on and off with the power buttom.

0

it sounds like the internal power supply is going bad. it is getting power to the distributor but it isn't sending power correctly.

that would be my guess

0

i guess you are right jermaghs07.

I have been to some sites which say, the problem is due to a dead chip called "MOSF power switch". Now my problem is how to locate this chip/chips on the board and replace them with new ones. I have the neccessary equipment and skills to change any kind of chip.

I will be happy if someone help me to loacate this "MOSF power switch"

Thanks

0

in most cases it is too expensive to just replace 1 chip on the motherboard and is cheaper just to buy a new motherboard. but if you are doing it yourself it might not be that bad. i would suggest getting a hold of toshiba and see if they can give you a schematic of the laptop hardware. normally tech support can give you something to go on.

hope this helps

0

another thing is you need to make sure that it hasn't harmed any of the other hardware in the computer before you just replace that one chip.

0

Dear sir
I have proble that display related. pc moniter for ok,
RAM for ok,SMPS for ok. solve my problem .
anythin masage (abcd.....)som no displa

0

Dear sir
I have proble that display related. pc moniter for ok,
RAM for ok,SMPS for ok. solve my problem .
anythin masage (abcd.....)som no displa

First of all i can't understand you!!!
second of all if you have a question regarding your own problem then you need to start a new thread. and please list as many details as you can and type legibly.

Thank you

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.