0

Hi folks

I have a Fujitsu-Siemens laptop - Amilo PI 1505 - which is just over 2 years old. Over that time four of the screws on the bottom of the case somehow fell out.

Now, recently I had a problem with the power supply where it wouldn't run off the mains unless I manipulated the lead at the connector. I wasn't sure if it was the lead or the connector on the laptop itself so I just carried on stuggling with it.

However, after a week or two, the ugly part came along...my laptop had been on for an hour when i rested it on my bed, turned my back for a moment, then saw a bit of grey smoke coming out of the vent on the side, next to the power supply. There was an odd smell as well, almost like smoky TCP. I moved it and turned it off, tried it a few hours later and it was working fine.

It worked as normal for a couple of weeks after this, until yesterday it wouldn't turn on, and there was no light to show the charge from the power supply. Last time I left it, I had shut it down, but I suppose there could have been an error message or something that prevented it from completing the shut down and turning off.

So is this a power supply or has the motherboard burnt out? My friend says the smoke is a bad sign but I'm clinging to those two weeks in which the laptop worked as normal since then!

2
Contributors
1
Reply
2
Views
8 Years
Discussion Span
Last Post by mechbas
0

The loose screws are/were fair warning. The mounting screws quite frequently make a ground connection to a major power connection. The AC adapt. is prob. o.k., can't say the same for the mobo. Have service personel give it a once over, if another screw helps, you're lucky, otherwise it's a new mobo.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.