0

Hello everybody,

I have a C640 Dell Latitude laptop, and it has double 256MB RAM modules, so my laptop should normally has 512MB RAM memory.
Sometimes laptop boots fine with 512MB, but usually it boots only with one module and then I got the message "The amount of system memory has changed".
I run on it Windows XP and Ubuntu, both of them shows
256MB or 512MB RAM memory. I checked at BIOS too, same.
I thought that its not inserted well second RAM module in slot, and I opened my laptop, checked the modules, all was fine. But the problem its still there. Does anybody know why this laptop does not boot always with both RAM modules, and how to fix it?

Thanks in advance.

3
Contributors
6
Replies
8
Views
8 Years
Discussion Span
Last Post by Tiga
0

Did you actually REMOVE the modules or just poke at'em?
Seems to me that you were already at the prob. source then!

0

Did you actually REMOVE the modules or just poke at'em?
Seems to me that you were already at the prob. source then!

Yes i did remove the modules, and i switched the sides of modules but usually still 256MB.

0

The contacts on mobo are of dirt and/or rust, if not that one module is DOA (extremely rare, give yourself benefit of doubt) Only place that I know of that actually checks modules is MicroCenter Marietta.
Clean module contacts with alcohol & allow to dry. Check for rust/dirt on mobo contacts. If you see dirt MAYBE it can be simply blown away w/can air or, alcohol clean and dry w/qtip. If rust, use light rouge cloth (hdwr. store, etc.) to clean THEN alcohol again.

0

Well, but there is no dust, dirt or rust in contacts, modules seems to be clean, anyway I followed your instructions and at first boots RAM was 512MB but later it came back again to 256MB. :(
Any other ideas?

0

Just try use 1 256mb RAM on different RAM slot.

Then use the other RAM again the same way, when you reach the system no boot, the RAM connecting to the system is faulty, if certain RAM slot caused no boot on both RAM, that slot maybe faulty.
This is not a software issue, you may need to swap a piece of 512mb RAM on the working slot(if you really need to have that much RAM on your system) or get the faulty RAM slot fix then.

Hope this helps!
Bill

0

Yes, this is a hardware issue and the second slot is not working. Because when i tried to boot only with a module in the second slot, it doesn't worked, also with the other RAM module. So, if there is not any way to fix it by myself, I'm going to buy a 1Gb RAM and put it in the first slot.

Thanks you all in advance.

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.