0

i gt latest amd phenom2 ..940 blck edition...3.0 ghz

and gigabyte GA-MA69VM-S2...

the prblm is ....

now its displayin

amd processor model unknown wid 2.3 ghz.... in device manger....

i chked on web abt supported CPUs for this model....

they hvnt mentioned this processor.....

will the processor deliver to its level..??shud i chng ma mthrboard......

3
Contributors
3
Replies
4
Views
8 Years
Discussion Span
Last Post by jbennet
0

well the first thing you need to do is update your bios, because if you bios does not know what cpu it is then windows wont aswell!and this motherboad supports the am2 cpus and the phenom is AM2+, this means that youre board will be able to start the cpu but it wont know what type it is until you update the bios, if your bios detects the cpu as the correct one then you need to update the driver for the cpu in windows, i had the same thing with my asus board and all i did was update the bios and it worked fine!So you will need to contact gigabyte and ask for a bios update or just have a look on their website

0

This is also posted on gigabytes site for your motherboard

*Note: If you install AMD AM2+ CPU on AM2 motherbord, the system bus speed will downgrade from HT3.0(5200MHz) to HT1.0(2000 MT/s) spec; however, the frequency of AM2+ CPU will not be impacted. Please refer "CPU Support List" for more information.

0

Thats normal. Windows doesnt detect the phenom as it wasnt invented when it came out. You need to install a hotfix.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.