0

This has happened before, but was easily fixed. When I turn my computer on everything boots nicely (after a full nights rest) After Windows XP fully boots, it locks up tight (no mouse movements or anything) for about 10-20 seconds and then when I open My Computer, my CD-Rom drives are gone with the wind. I fixed this before by opening up my computer and taking out all the IDE's for the CD-Roms, and the power cords, and starting windows, and removing the drivers for the IDE's, shutting it down, and letting it cool before I put the cords back in. Then they worked, but now when I do it, they shut down before I can even open windows. I'm not sure what the dillio is here. It's different, and I'm hoping someone out there has the capability to help me out. Worst comes to worst, I'll just make a new computer, and I'll make this one go BOOM! :twisted:

2
Contributors
8
Replies
9
Views
12 Years
Discussion Span
Last Post by eXistenZ
0

Sounds like you have more than one CD drive. Have you tried to narrow things down by troubleshooting with only one of the drives installed at a time?

When you say "they shut down", to you mean that the system just powers down by itself shorlty after it finishes loading Windows, or do you mean something else?

0

The wierd thing is they both still have power, (They open and shut) But the system no longer detects them. I have tryed only one CD-Rom, and I have even gone as far as replacing both of them. Nothing. One of the possibilities I came up with, was maybe the powersupply isn't strong enough to support both of them for a certain period of time? Maybe a virus? Maybe not, it dosn't even detect them in the Bios after they fail.

0

The BIOS issue makes me think this isn't the problem, but here's a link to a common cause of disappearing CD drives:

http://support.microsoft.com/kb/q270008/

Although the article pertains to Win 2000, I've seen the problem occur with XP as well; the fix described for Win 2000 works for XP.

Please note that although the article only refers to the "UpperFilters" and "LowerFilters" entries in the HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet registry subkey, I've had to apply the fix to the similar entries (if found) in any other HKEY_LOCAL_MACHINE\SYSTEM\ControlSet00x subkeys as well in order to make it work.

0

Do I delete the .Bak entries as well as the upper an lower filters?

0

To be honest, I don't remeber if there normally are .BAK entries under those subkeys. Just delete the keys exactly as instructed in the link I gave and see if that does anything to help the problem.

0

I finally got around to deleting thoes keys, I feard it for the longest time since I've had some pretty bad luck deleting stuff off the registry. No go. CD Rom's still have power but no ability. BIOS still says "Detecting Primary (Master/Slave)........(Press F4 to Skip)Not Detected" I'm still thinking the power supply is too weak to support all of the stuff, because the last one fried while in the machine. This really bites.

0

Here's a link that lists the power usage (in Watts) of common computer components; use it as a rough guide to see if your power supply's wattage rating measures up:

http://computer.howstuffworks.com/power-supply3.htm

If you've only got a 250W supply, and your machine is relatively fully stocked with components, I'd get a beefier supply.
Of course, if the power supply is of sufficient rated wattage but just isn't providing as much "oomph" as it should, that's a different story.
One thing to remember about weak/failing power supplies (or weak batteries, for that matter) is that they will often appear to be putting out the right voltages if you measure them with a voltmeter, but will not be supplying enough current, and current is a bit more difficult to accurately measure than voltage.

Before you go out and pay for a new power supply though, replace the IDE ribbon cable on the CDs with another cable that's known to be in good, working condition if you haven't done that already. Also, it is possible that the IDE channel that the CDs are connected to is faulty, which would be a bummer- there's not much you can do there except replace the mobo...

0

Well I'm going to thank you for all your help, but this will knock your socks off. I had the CD-Roms working for about a day, with the computer out of it's hole and the side pannel off. I tried about 5 different IDE cables before they finally worked. Anyways, when I put it back in, it locked up and the CD Drives were once again... gone. What in the hell? Yeah, I'm going to kick back and enjoy a beer while you figure that one out.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.