0

Hi there

I have a problem with my home built PC.

I was working away everything fine, then I couldn't get the mouse pointer on screen to move (mouse basically stopped working) then everything simply went dead. Shut down completely.

Not sure if the mouse dying first is relevant but it is making me wonder if it is a problem with my motherboard or processor. I can switch PC on and the fans go on along with everything else but no beeps or picture or bootup. I am stumped, the details of what I am running are in my profile, I would appreciate any advice/help at all.

Many thanks

Kiatora

4
Contributors
5
Replies
6
Views
8 Years
Discussion Span
Last Post by Kiatora
0

Seems like your CPU is dead.

Only thing you could do is disconnect all the drives, all but one stick of RAM and clear CMOS, then try to turn it on (while everything is D/C-ed) to see if it would spring back to life.

Also, reseat the VGA, while you're at it.

If that don't make any changes, remove VGA and turn it on. If you hear beeps, then your VGA is busted, and not CPU.

0

Seems like your CPU is dead.

Only thing you could do is disconnect all the drives, all but one stick of RAM and clear CMOS, then try to turn it on (while everything is D/C-ed) to see if it would spring back to life.

Also, reseat the VGA, while you're at it.

If that don't make any changes, remove VGA and turn it on. If you hear beeps, then your VGA is busted, and not CPU.

it seems problem with M/B but to take any decision firstly to check with remove ram if beep sound wil come then dont worry about motherboard it wil come problem in ram but if no beep sound then u may get invest some more money for new M/b. try to repair with local vendor if possible other than no any options remain.

0

Hey there

I tried everything from previous post and no joy, I did however get constand beeps when no ram was fitted. I will try individual ram next and see how that goes, thanks for the idea, its the one ting i didnt try yet. will let u know outcome

it seems problem with M/B but to take any decision firstly to check with remove ram if beep sound wil come then dont worry about motherboard it wil come problem in ram but if no beep sound then u may get invest some more money for new M/b. try to repair with local vendor if possible other than no any options remain.

0

Hey there

I tried everything from previous post and no joy, I did however get constand beeps when no ram was fitted. I will try individual ram next and see how that goes, thanks for the idea, its the one ting i didnt try yet. will let u know outcome

checked the ram and no change, checked for shorting with mb etc etc etc, last ditch attempt is to try old psu i have laying around and see if its perhaps that which is the problem as it is my last step before giving up i think, will let u know how it goes
Kayelar x

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.