0

I have had this problem for a while now. It started when my "I" storage drive (which holds all my music and photos) was there one day and gone the next. It sometimes re appeared but now has gone and i can not access it.
I checked the Bios and it had gone from there but after swapping sata cables it then shows back as Sata 3 on the Bios. I checked and both settings were set to Auto the same as my Sata 2 drive and IDE drive (primary).
I thought this had fixed it but looking at my computer it still did not show up.
I then went to computer management and checked if it showed up in disk management. In there it only shows my main drive and my second Sata drive (along with my DVDRW, virtual drive and removable drive) no sign of my "I" drive.
Would anyone have any help as to how to get my system to recognise this drive again?
I am running Windows Vista Ultimate with an AMD Athlon 64x2 Dual core processor 5000+ with 4GB RAM. NVIDIA GeForce 9800 GTX/9800 GTX+
Any help would be much apreciated. Thanks in advance.

3
Contributors
5
Replies
6
Views
8 Years
Discussion Span
Last Post by Pigzy
0

You're not gonna like any of this. Seems to me that your drive has had it. The drive's onboard controller circuitry has failed. The only good news is that the info that's actually on the drive platter(s) is mostly still there unless the heads themselves have crashed into the platter(s). The really bad news is that drive recovery operations are quite expensive.

Edited by mechbas: n/a

0

Thanks for responding mechbas. I was thinking the drive may be kaput but was living in hope lol. I have still not done anything with it yet, i have been looking to install windows 7 as my vista ultimate seems not to like starting up. I have to re set it straight after start or i get a black screen....which i started to think may also be contrabuting to the missing drive (fingers were still crossed lol). Once i get round to installing and if the drive is still not there i will get a mate who does disk recovery to get my data. May take some time to get round to it as i can not find the time at the moment with my new born son getting all my attention. I only get to mes with pc between his sleeps just now lol. I will report back once i install windows 7. Thanks again

0

yes sounds like the drive is dead, just curious though, is it an external? and what bios are you running? I had a similar problem with an external drive and the phoenix bios, turned out it was a bios problem reading over usb in the boot. found out i could just put the drive inside my comp and grab the data there.

Edited by Ponomous: n/a

0

Thanks ponomous for replying. Nope it is an internal drive. I think my bios ASUS as that is what my motherboard is. I am not too clued up on that side. I know how to access but don't know enough to interfear with that much setings. It is one part that i have not delt too much with and keep meaning to learn up a bit more.

0

Right i finaly got round to looking into this further. The hard drive waas the problem. I took the drive out and it fixed my start up problem as well. Not got round to doing a recovery yet but will do. Thanks to all who replied and sorry for taking so long to look into it myself further.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.