0

Everyone!

First, forgive me...I'm new to the forum. I've been looking around and have not found my answer and wondering if you all can help.

I have a Maxtor One-Touch 250GB USB/Firewire external HD. Today...it made a bunch of weird noises when coping files to it and then it came up with an I/O error. Basically WinXP Home Edition on my system recognizes the drive in My Computer as a local disk with a drive letter. But when I click on the drive I get a "Request could not be preformed because of a I/O device error".

I'm looking to see how I can access the data? I've seen some information on this program "KNOPPIX" which I'm seeing is a program you put on CD to boot the computer with to view the files (correct me if I'm wrong). It there another program to move the files?

I tried going to the Maxtor website and finding HD tools, I could not find them. I'm used to using tools like Western Digital has that you can boot from disk, view the harddrive and possible fix any bad sectors or what have you.

The harddrive boots, it's recognized by Windows...so I'm thinking software can possibly do it...but not sure what software.

Anyhelp would be great as this HD has my files from Iraq (just got back) and I was working on doing a back up to DVD this week. Thanks!

Jimbo

2
Contributors
1
Reply
2
Views
10 Years
Discussion Span
Last Post by VickiBraun
0

Hey, Jimbo, I tried to post long message, but the forum ate it. (I registered just to answer your post.) Don't have patience to rewrite everything, but I had same experience. Did lots of research, chkdsk, tried recovery tools, etc. One word: SpinRite Funky, but it worked (and was worth every penny of the $100) When you are done, toss that boat anchor, b/c Maxtors are infamous for crashing this way!

Good luck!

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.