Hi, I have a G4 running 10.4 and a Canon 400d, I have been
Using this camera for two years on the same mac g4 computer it now will not recognize it. I have tried the flash card in a number of readers and joining the camera to the computer with different cables to no avail. The computers system profiler sees the camera and the card reader but they will not show up when I start any photo application including image browser Apeture and iphoto. I have repaired permissions run disk warrior and trashed the cache, still nothing. Have you any ideas please? Connor

The more recent your photo apps, the more likely the drivers (extensions) are to be the culprit.

However, to get through, does your flash card show-up on the desktop...where you can just drag images to a folder and then use Bridge/Apeture etc.

Sounds like you've been upgrading the system for quite some time since it's a g4... have you tried hitting Cannon's site for new drivers?

Just a quick one.....
Have you tried the camera on another computer? Is it recognised on any other machine, same goes for the card in a card reader, is it readable from another PC or MAC?

Hi, yes the camera is recognized by other computers and I have tried the cards in a cf reader but it is old so I am not sure that it works.So I have to now borrow a friends comp to upload the photos and transfer them to mine, but I work mostly mobile so it is important to get it recognzing my camera. I recently, around the time of the error, installed a hewlett packard software that I dont even need which I suppose could be the problem, I did a find and deleted all Hp items, but it still does not recognize the camera. I find in activity viewer a hp io activity, I do not know what this is but it means that hp is still active somewhere. What a mystery!

Have you tried restarting the machine with the camera unplugged, going into Activity Monitor inside Utilities then Quitting the HP process, then plugging the camera in to see if it is mounted. That would at least tell whether that Process is causing an issue.

Also, you said that you can see the device in System Profiler... When you go into Disk Utility can you see the Card, mounted or unmounted, in the left pane?

Just as another check, have you put a different CF card into the camera or card reader to check it is not just an issue with the card or card formatting? I know it's a dim one but it cuts out some simple possibilities.

Hi Madaxe, I tried all those possibilities with no results im afraid. I just tried a very similar canon camera and the photo app started first time. It must have something to do with my camera, but I cannot find any setting to change connection status on the camera, most baffling!

Well there isn't much more I can suggest unfortunately apart from grabbing the software from this link... http://driverscollection.com/?H=EOS%20400D&By=Canon or the Canon site, making sure you have all the latest but making sure you delete the older installation of your software first. That said, with the mac pretty much every external storage device should be mounted without need for software whatsoever, but that is all I can really think of i'm afraid. Let me know if you have any success or change in issue though.
Hope you can sort it!

Be a part of the DaniWeb community

We're a friendly, industry-focused community of developers, IT pros, digital marketers, and technology enthusiasts meeting, networking, learning, and sharing knowledge.