0

Hi , be grateful for ideas/help re a Kingston Data Traveller 4 gig. Just got this to do a smallish backup , but although my machine recognises it , it won't allow it to operate , although 2 other "lipstick " drives , (sandisc ) work perfectly . I've been through control panel -hardware and the device is there with a yellow question mark against it . When I click re-install drivers it does the search bit , and then says can't install because it can't find drivers . I understand the Windows should have the drivers already , but still no success . This machine is a Mesh desktop , 2 gig memory Asus motherboard running W XP home with all updates . Any help gratefully received TIA perfidia

3
Contributors
5
Replies
6
Views
8 Years
Discussion Span
Last Post by perfidia
0

Don't Know - I haven't got another computer to try it . There's presumably some kind of activity within the drive because it shows a little intermittant blue light . It also shows up in "hardware " dev. man . as" data traveller 2" so I suppose the computer knows what its got . . I've tried it in different USB ports and it isn't in a hub , in any case the sandisc works perfectly in the same port , but I have used that one before . I've also tried an unused non branded 256 meg one , and that doesn't work either . So I can't think it's a faulty stick - not two together surely ? But I wonder what kind of computer glitch would give me these faults - Windows XP or hardware ? :(

0

Two bad sticks in a row is a little strange, but bad hardware is not uncommon. Yet I have to ask...

Are you 'safely removing the drive' ?

I ask because if data is traveling to the drive while being removed it will cause damage to the drive.

0

Yes , certainly removing the stick correctly . Tried both the non Working sticks , and the one that works in my son's computer today , and they were all recognised and ready to write to , so I can only assume a problem with my machine 's USB ports , or perhaps the software operating them (Possible ?) And if so what's the work around . I'm using an Epson printer in one USB port and that works OK . Also Fuji camera and Nokia phone software , BUT both these were up 'n running before this trouble . Thanks for your trouble and help , I could use a bit more though !!

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.