0

i have no idea what has happened to it, was working fine yesterday :confused:

it turns on, goes past the bios page and then remains black with the blinking underscore. i used chkdsk on the recovery console whch did nothing and tried to repair the existing OS but when it restarted after the setup it returned to the black screen.

that pretty much all i have on this iv got no other info for you so any help would be greatly appreciated

4
Contributors
28
Replies
29
Views
8 Years
Discussion Span
Last Post by dan_6464
Featured Replies
  • Yes I think that will work. But if doesn't work you may have to reinstall the OS, if it comes to this then you can back up your data using a linux live cd. Or If you have a large hard drive you could install XP on another partition and … Read More

0

Hello,

Do you have any usb devices connected?

Can you do a hard drive test from the BIOS?

0

no usb devices connected no, what do you mean by a hard drive test?

0

no usb devices connected no, what do you mean by a hard drive test?

If you enter BIOS there may be an option to test the hard disk try pressing DEL / F10 / F11.

The test will take some time.

Something else to try, have you any bootable CD's like Linux, if you do try them.

0

i have the xp disk that was supplied with laptop, il try the hard drive test now

0

Okay...

If you have the XP cd have you tried using that to fix XP? If the Hard drive test passed, try fixing it.

0

i cant seem to find this test, the options given to me is f12 for the boot menu, tab for the raid and f2 for setup. del, f10 and f11 didnt do anything.

i tried fixing with cd but after it restarted after the setup it returned to the black screen

0

Right...

Try entering setup(F2) and see if there is an option for testing hardware and select hard drive.

The last option will be to reinstall XP but leave that option till later.

Do you have important data on their you want to save?

0

im on the setup menu but theres not much here tbh, i remember being on this before and theres alot less here than i think there used to be. for example the safe mode button isnt there. so what exactly shud i be lookin for? wud it be under Main, Info, Advanced, security, power or boot subheadings?

Theres data i do wish to save which is quite ironic seeing as i turned on the laptop to back everything up :( a day to late it seems

0

I would expect it to be under Advanced. Whilst you are in BIOS can you check that the hard drive is still in the boot order near the top in the boot tab.

If we can't sort out the problem I recommend getting a linux live CD and copy the files you want to an external hard drive.

0

the only thing under advanced is 'execute disable bit', its enabled if that helps

the boot order is
1:usb key:
2:usb fdc:
3:usb cdrom:
4:usb Hdd
5:IDE CD: Optiarc DVD RW AD-7540A-(
6:IDE HDD:
7: PCI BEV:
8:RAID: FUJITSU MHV2090BH

Excluded from boot order:
: RAID: FUJITSU MHV 2080BH
:Other USB:
: PCI :

im guessin that the raid shudnt be excluded?

0

Boot order looks all right. RAID can be excluded as you are after booting from hard drive.

Can you get into safe mode or anything by pressing F8 after the POST screen?

0

so do you reckon i shud try a reair install or do a fixmbr on recovery console?

1

Yes I think that will work.

But if doesn't work you may have to reinstall the OS, if it comes to this then you can back up your data using a linux live cd.

Or If you have a large hard drive you could install XP on another partition and transfer the data over.

0

i tried the repair install again to no avail.

will fixmbr wipe my data because if it will il try this linux live

0

where would i find linux live i googled it and not sure which to choose.

is it the knoppix one?

0

fixmbr only fixes the master boot record data will not be affected.

I Like to use Ubuntu. Download the .iso and burn it to CD using ImgBurn then boot using the CD and copy the files you want to external hard drive.

0

well i did fixmbr and it allowed the resuming windows page to come back on after it restarted. but it then came up with several error messages and then shut itself down

it restarted saying a file is missing or corrupt, being
<windows root>\system32\hal.dll.

0

Alright, now we know a bit more.

Can you go back into the recovery console and type chkdsk volume: /r replace 'volume' with the drive letter or just try typing chkdsk /r this should repair some errors on disk.

0

ok its doing it now, iv done this before but it was before i did the fixmbr so hopefully il get more results now

0

it took over 40 mins when i tried this yesterday so any tips incase your not here when its finally done :)

0

something strange, when i went onto recovery console i didnt have to select 1 or enter the admin password i could straight away type in chkdsk.

thought it may of been significant

this chkdsk takes ages lol

0

If the HAL error persists then check out this link Here.

If you manage to fix it I suggest running that backup pretty soon.

0

i did the chkdsk /r still have the error :(

doing that link now

0

Try If you want to check the disk in drive D and have Windows fix errors, type:

chkdsk d: /f

/f Fixes errors on the disk. The disk must be locked. If chkdsk cannot lock the drive, a message appears that asks you if you want to check the drive the next time you restart the computer.


or

Press f2 to enter setup first boot device Cd/Dvd and second is the hard disk that you want to install the new xp,save changes,place the xp installer into the cd/dvd drive restart the computer press a key when asked and follow the isntructions(F8 I agree,format Ntfs,go....)

0

i managed to get onto ubuntu, its pretty kl actually, so im thinking il save all my data onto a backup and then clean install of xp?

i later look into using ubuntu tho it is pretty kl

0

hey, managed to use linux to backup my files so im now in the process of reinstalling xp :)
thanks for all the help il have to refer to the article on reinstalling xp now

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.