0

A while back I tried to install Windows XP on my computer. I was not able to because Windows 98 was already installed. Since then I changed my mind and continued using Windows 98. Now, because I started the install of XP I have this error message whenever the computer starts. It goes to the message "Please select the operating system to start" and if your not quick enough it will go through the whole XP setup thing again. It is quite annoying and would love to get rid of this thing that obviously contains some sort of setup data that stays on my computer. can anyone help me to REMOVE the setup data so I can just boot right to Windows 98 like I use to? Thank you very much!

15
Contributors
23
Replies
25
Views
13 Years
Discussion Span
Last Post by DMR
0

wow ima hafta think about this....

last time i checked windows 9x serries didnt have a boot manager....

my best suggestion to you would be to try to find the isntall data on your hd and remove it...

however im not sure what type of damange this could cause :\

0

That's not an error message ,actually it is a boot manager when you install your windows XP(full install)
" when you see the prompt,upgrade (recomended). And
full install = that means it will install another version of windows in your PC."

Iam not sure how to get rid of it ,however if you still have restore disk of windows 98 . You can re-install it
and get rid of that boot manager.

LEX,

0

This is copy paste from another site ,the OS's are switched around but the cure should work for you

Give dual boot the boot

Q: I installed Windows XP on a new hard drive in my PC, but I kept the old drive containing Windows 98 SE as my D: drive. Windows XP apparently detected the 98 SE operating system on the old drive and now offers me the choice of dual-booting at start-up. How do I get rid of this option?

A: You'll need to edit the boot menu, which is controlled by the C:\boot.ini file on your Windows NT, 2000, or XP boot drive. This small text file contains various parameters that control the boot-up delay (Timeout=), the default operating system, and information about which drive and partition contain your two operating systems. Your current boot.ini file probably looks similar to this:

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Home"
D:\="Microsoft Windows 98"

To access the boot.ini file, click Start, right-click My Computer, select Properties > Advanced, then click the Settings button under Startup And Recovery. In the Startup And Recovery dialog, click the Edit button under System Startup. This will open the boot.ini file with Windows' Notepad program.

To open the file without the long string of dialogs (using Notepad or another text editor), you must first remove the file's read-only attribute. To do so, click Start > Run and type cmd. Click OK, and you'll see a command-line dialog. At the command prompt, type CD\, then press Enter. Now type attrib -r -a -s -h boot.ini (note the spaces between command letters and the hyphen for the next letter) and press Enter. This will remove file attributes that would prevent you from editing the file. Next, type notepad boot.ini and press Enter to open and edit the file.

Now, to remove the Windows 98 boot option, simply delete this line: D:\="Microsoft Windows 98." Without the line, Windows XP becomes the default start-up OS. If you prefer to leave the dual-boot feature as is, but you want Windows to start the default operating system sooner, simply replace the number after Timeout= to something less than 30 seconds. (Windows will present you with a dual-boot option, but it will launch XP within the time you specify.) When you have completed your edit, save the file and close Notepad.

0

I see where that Boot.ini files exists and I tried modifying it. However, no matter what I change it to it always goes to Windows XP Setup by default. I did change my timeout to 50 seconds which is better because it gives you more time to select Windows 98 at startup. I checked another computer and notice that Boot.ini is not even in Windows 98 anywhere on the other computer. So apparantly, Windows XP setup put this in C: in Win 98. I was going to delete it, but am afraid to, might cause boot failure? But it seems if I would delete it, maybe it wont come on at all? I know the Windows XP setup files exist somewhere, but darned if I know where?

0

...I was going to delete it, but am afraid to, might cause boot failure?...

seems to me that with the probs you're experiencing you might want to do a comprehensive back up just to be save. btw, did you try runing scanreg /restore & selecting a date prior to the attempted WinXP install? make sure you know what that command does before running it.

0

What happened was that XP setup wrote a new boot sector, pretty much erasing any existence of a plain vanilla 98 installation.

You can't really do anything about it other than format and start over, along with an fdisk /mbr before you reinstall 98.

0

You can't really do anything about it other than format and start over, along with an fdisk /mbr before you reinstall 98.

Restoring the MBR by running "fdisk /mbr" from a Win 98/DOS rescue disk might do the trick by itself; worth a try before you go for a full reformat.

0

Well it seems like this was a serious deal here, no way to get rid of it but thank you caperjack by accessing the Boot.INI in C: I was able to change the Timeout from 5 to 55 seconds so now when i boot up I have time to select before the darn things goes into that Windows XP setup deal again. I would always miss it before, because if you look away or are not paying attention at boot up, your 5 seconds are up. So having the minute to respond is working fine and seems like a better way to go then a complete reinstall of Win 98. Other then that, the computer seems to run pretty good plus too many files to backup and restore. Thanks to everyone for all the feedback.

0

This is copy paste from another site ,the OS's are switched around but the cure should work for you

Give dual boot the boot

Q: I installed Windows XP on a new hard drive in my PC, but I kept the old drive containing Windows 98 SE as my D: drive. Windows XP apparently detected the 98 SE operating system on the old drive and now offers me the choice of dual-booting at start-up. How do I get rid of this option?

A: You'll need to edit the boot menu, which is controlled by the C:\boot.ini file on your Windows NT, 2000, or XP boot drive. This small text file contains various parameters that control the boot-up delay (Timeout=), the default operating system, and information about which drive and partition contain your two operating systems. Your current boot.ini file probably looks similar to this:

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Home"
D:\="Microsoft Windows 98"

To access the boot.ini file, click Start, right-click My Computer, select Properties > Advanced, then click the Settings button under Startup And Recovery. In the Startup And Recovery dialog, click the Edit button under System Startup. This will open the boot.ini file with Windows' Notepad program.

To open the file without the long string of dialogs (using Notepad or another text editor), you must first remove the file's read-only attribute. To do so, click Start > Run and type cmd. Click OK, and you'll see a command-line dialog. At the command prompt, type CD\, then press Enter. Now type attrib -r -a -s -h boot.ini (note the spaces between command letters and the hyphen for the next letter) and press Enter. This will remove file attributes that would prevent you from editing the file. Next, type notepad boot.ini and press Enter to open and edit the file.

Now, to remove the Windows 98 boot option, simply delete this line: D:\="Microsoft Windows 98." Without the line, Windows XP becomes the default start-up OS. If you prefer to leave the dual-boot feature as is, but you want Windows to start the default operating system sooner, simply replace the number after Timeout= to something less than 30 seconds. (Windows will present you with a dual-boot option, but it will launch XP within the time you specify.) When you have completed your edit, save the file and close Notepad.

I had this same type of prob. your info got me on the right track. I was able to use your info and figure out what I needed to do in my situation. It was a guess, I did'nt know if it would work, but I had to try it and it did I thank you for your time and your knowlage. It has been a great privilege Thank You Cyrus

0

I had this same type of prob. your info got me on the right track. I was able to use your info and figure out what I needed to do in my situation. It was a guess, I didn't know if it would work, but I had to try it and it did I thank you for your time and your knowledge. It has been a great privilege Thank You Cyrus

It was like reminiscing for me to go all the way back to 2003!
Actually its not my knowledge,just a good Google!:)

0

edit the boot.ini file
set default on w98
if that works; set timeout = 0

no screen anymore!

mifa

0

edit the boot.ini file
set default on w98
if that works; set timeout = 0

no screen anymore!

mifa

Exactly. I know this is an old post, but if you wanted to change it, this would be the trick:

old one

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Home"
D:\="Microsoft Windows 98"

New one should be changed to:

[boot loader]
timeout=0
default=D:\
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Home"
D:\="Microsoft Windows 98"

That should do the trick.

0

Thanks alc6379, I had the exact same problem as SteveMor909, on a friends computer, and after much searching, your solution worked for me.
Old Boot.ini:-
[Boot Loader]
Timeout=5
Default=C:\$WIN_NT$.~BT\BOOTSECT.DAT
[Operating Systems]
C:\$WIN_NT$.~BT\BOOTSECT.DAT="Microsoft Windows XP Professional Setup"
C:\="Microsoft Windows"

New Boot.ini:-
[Boot Loader]
Timeout=0
Default=C:\
[Operating Systems]
C:\="Microsoft Windows 98"

Computer now boots straight into Win98

Also discovered a relevant Microsoft Article "Microsoft Windows XP Setup Remains in Boot.ini" http://support.microsoft.com/default.aspx?scid=kb;en-us;827324&Product=winxp
which gives an alternative solution and also explains where the XP Setup folders are located ("In the Drive C window, delete the following folders: •$win_nt$.~bt •$win_nt$.~ls")

0

what about fdisk /mbr from dos? It works for getting rid of other loaders like grub. BEWARE IT MAY "BREAK" YOUR SYSTEM!

0

I had the same problem, but my fix went like this:

Click Start, select Run, type msconfig, and click OK. This opens the system configuration utility. Click the BOOT.INI tab, select the correct option (OS) for your situation (if it isn't already highlighted), and then click "Set as Default". Restart.

In my case, I had a choice between Windows XP Professional and Windows XP Professional Setup. I selected the former, set it as the default, and restarted. Sure enough, it defaulted to WinXP instead of Setup. I didn't even bother changing the timeout - I'm just happy that I can power up and step away knowing that Windows will start normally!

0

A while back I tried to install Windows XP on my computer. I was not able to because Windows 98 was already installed. Since then I changed my mind and continued using Windows 98. Now, because I started the install of XP I have this error message whenever the computer starts. It goes to the message "Please select the operating system to start" and if your not quick enough it will go through the whole XP setup thing again. It is quite annoying and would love to get rid of this thing that obviously contains some sort of setup data that stays on my computer. can anyone help me to REMOVE the setup data so I can just boot right to Windows 98 like I use to? Thank you very much!

old school was always better .. but not in this case.
win 98 is old ... is like riding a 20 years old horse when you have a full young pack to choose from.

anyway, to get it right just format it all and install the new system

0

Another new addition to a very old topic, gotta keep em' alive I guess. :)
I tried my own solution to this one before doing any research at all and guees what, I screwed up big time. I moved all of my "boot loader" files out of the root and into another directory, yes I now know this was stupid. I thought I could just boot from a floppy and move them back but now I can't get access to my C: drive at all. Tried several different boot disks (DOS, Win98, Win2k) but I still can't see my harddrive. Also tried booting to a "boot loader" disk but that doesn't seem to work either. Anyone have any ideas what else I can try? Anyone know of a way to force your PC (via a floppy) to point to another directory on C: for the boot info? I'm running out of ideas.

0

Hi damnesiac,

First of all- welcome to DaniWeb :)

Another new addition to a very old topic, gotta keep em' alive I guess.

Actually, we try to let old topic rest in peace. :p

For a couple of reasons, we ask that members not tag their questions on to a thread previously started by another member (regardless of how similar your problem might seem). Not only does it divert the focus of the thread away from the original poster's problem, but it also makes it less likely that you yourself will get the individual attention that you need.

Please start your own thread and post your question there. When you do, please give us as much specific info as possible regarding the problem (exact error messages, system specs, troubleshooting steps you've already tried, etc.).

For a full description of our posting guidelines and general rules of conduct, please see this page:

http://www.daniweb.com/techtalkforums/faq.php?faq=daniweb_policies

Thanks for understanding.

0

As this thread is nearly 3 years old, and the original poster has indicated that they found a viable solution to their problem, this thread is considered solved and has been closed.

In accordance with our posting rules, other members having similar questions or problems need to start their own threads and post their questions there.
In order to help us help you most quickly, please include as much information about your problem as possible in your posts.

If the member who originally started this thread wishes to have the thread reopened, please send your request, including a link to this thread, to one of our moderators via email or Private Message.

Thank you.

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.