0

Afternoon to you all. I've got an annoying glitch which i can't get rid of. I'm running Vista home premium on an Acer laptop, with an ATI Radeon HD 3470 graphics card, but the computer says that i'm using the wrong driver, and i'm getting a white screen flicker which completely covers the screen, and seems to have a horizontal orientation. Can anyone recommend a solution? I'm seriously thinking about throwing this damn laptop!

3
Contributors
7
Replies
8
Views
8 Years
Discussion Span
Last Post by scotsrocket
0

Did this happen suddenly?

if so, what's changed or been added?

In Safe Mode you should be using the VGA BIOS in the Radeon and you could probably sort it out from there.

0

Do you have installed any driver? If yes , is the good one? Check on producer page for a new version of driver.

0

I updated the driver from the ATI website, and it happened when I rebooted. Is there any way to roll back the driver?

0

I updated the driver from the ATI website, and it happened when I rebooted. Is there any way to roll back the driver?

On the adapter properties page/driver you can roll back. At least it should offer roll back.

0

I can't find it. can you tell me how to get to the menu you are describing please?

0

I can't find it. can you tell me how to get to the menu you are describing please?

Conntrol Panel/Device Manager/Display adapters/ATI Radeon HD3470/Properties/Driver tab --> Roll Back Driver button

I hope.

0

Just posting to say problem solved. Many thanks, Suspicio. Although, it does strike me as truly daft that ATI will publish updates that don't work!

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.