0

Hi everyboby!
I have 2 pc's in my office with XP home SP2 which are connected to a hub.
Also the dsl modem is connected to the hub. I made the 2 pc's to share folders on the network and the problem is as follows:The 1st pc is called VERO2 and the 2nd Vero_1. VERO2 can access the folders on Vero_1, but the opposite isn't working(The error message says that i haven't permission to access the computer). I have 2 identical accounts on both machines with the same username and password, the windows firewall is disabled and the mcaffee firewall is tuned to permit access to the IP's of my machines.
I've read that filesharing on XP Home is very tricky, so i'd appreciate any help or suggestions that you may give me!

Thank you!!

2
Contributors
1
Reply
2
Views
12 Years
Discussion Span
Last Post by navyjax2
0

The fact that you're using a hub instead of a router could be an issue in and of itself, but for a separate reason than file sharing, so for the sake of argument I'll assume that you have internet connectivity and DHCP has assigned your computer's IPs, and I'll let that slide. You can check this by doing a Start -> Run, then type in "ipconfig /all" (no quotes) and see if DHCP Enabled is "Yes" under your "Ethernet adapter Local Area Connection". If you do have internet on these computers I'm sure it is "Yes". I would do this on both computers, anyway, to verify DHCP is enabled and that they are not sharing the same IP address.

(Why use a router instead of a hub --- If your Internet Service Provider (ISP) had assigned & given you a static IP address, or switched to this form of addressing, and you set up both computers with this IP, or under DHCP/automatic addressing, you would not have internet in this configuration, as both computers would need to have different IPs and ones that conformed to the ISP's network. A router separates you onto your own network, away from all that. But while using a hub, the ISP would not be supplying DHCP in order for you to receive any address, so setting them up for automatically receiving an IP does no good, since they already gave you one by telling you what to use. If you have DHCP enabled, they get APIPA addresses instead that the ISP's servers won't recognize as valid on its network.

If you put the valid IP the ISP gave you on both computers, they would conflict and could cause a problem similar to what you are seeing - only one computer would win and get internet if either of them did - whichever was the fastest at connecting to the ISP's DNS server on the other end and registering its MAC address for the given IP. The other would be shut off the network, but entirely, not just one way like you are seeing.

If you set the other up to have a different IP, it would likely get kicked out by the server since it would probably already belong to someone else or be outside the reservation group, or get kicked by the network guys when they checked what IPs were being leased by customers and saw you active with your "rogue" IP, if you managed to guess one that was active and not taken.)

OK, I'm off my soapbox now. Just tired of people thinking routers and switches/hubs are all the same. Switches and hubs are alike, but are not routers nor meant to be used for them. On to solving your issue ---

Vero_1 is fine if you can access its share(s) from Vero2. That one is done. It sounds like you have a permissions issue on Vero2, so go to Vero2.

Right-click "My Network Places" on your Start Menu (if it isn't there because you haven't customized XP to put it there, right-click "Start", hit Properties, "Customize" on the Start Menu tab, then "Advanced" tab, scroll to find "My Network Places", check the box, hit OK twice.), hit Properties to bring up Network Connections. Click the Network Setup Wizard link or shortcut. Hit Next at the welcome screen, next at the "Before you continue...", you may get a "Do you want to use the shared connection?" prompt for the internet connection, or it may ask you what device you use to get internet outright. If it asks about a shared connection, say to let you choose another way to connect. If you get a prompt for what device to connect with, choose "Local Area Connection" - your Ethernet adapter. Hit "Other" on the first page asking you to choose a connection method. Select "This computer connects directly to the Internet. I don't have a connection yet." on the next page - This one always works no matter what, so if it's a lie, select it anyway, hit Next. Select "Local Area Connection" - your Ethernet adapter - for the Internet connection, and hit Next. This should get you to where it assigns permissions and creates a Shared Documents folder in C:\Documents and Settings\All Users. (If not, you should be able to muddle your way until you do see it doing this - that was as far as I was willing to take the Network wizard so it didn't screw up MY file sharing I already have in place.) At the end of the permissions assigning, just say you are done and don't create any wizard disks (it's for pre-XP only, and even then very unnecessary). Go to C:\Documents and Settings\All Users. Right-click the Documents folder there and hit "Sharing and Security". Make sure the folder has a check in the box to be shared, and take note of the name used to share it. You may change this if you like to anything you want as long as it doesn't have illegal characters like /, ?, etc. You'll want it to not have spaces so you don't have to type quotes around its address to bring up the folder everytime, however, and 8 characters or less is preferred if you will be accessing it with DOS at any point. You now can go back to Vero_1.

On Vero_1, go to Start, Run, type in "\\Vero2" (quotes unnecessary but should still work). You should be able to access the computer now, and see the shared folder created by the network wizard. If you still receive an error, reboot Vero2 and repeat this paragraph and it should work fine. Also, if you go to Start, Run, type in "cmd" (no quotes), then type

ping Vero2

at the prompt, you can verify if it is online (has connectivity - an active Ethernet signal). If it times out, ensure that Vero2's Ethernet cable is plugged in securely to the hub and NIC, check the link lights at the connection of the cable to the computer (if applicable) to see if one is solid, the other blinking to signify activity. Good luck.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.