0

Hi
I had and still look after a Asus A6Km A6000 laptop.
Recently it has been returned to me with keyboard issues.

I have been down the track of:

physically removing the keyboard to be sure that component is fine ~ it is

I have been able to flash the bios ( from within the bios system ) again all fine

I have updated all relevant Asus drivers ( though the touchpad 'Synaptic' has one the keyboard doesn't specifically have one )

And tonight I'ld thought I'ld have a go at recovering Vista Ultimate ( Which has run fine for some time on this system ) but no joy 'cause I get to having to enter the Administrators password at a cmd prompt and though I know it the keyboard issues prevent me from proceeding,

So how do I know this is a keyboard - touchpad conflict issue.

When first booting up and going to the bios settings I'm required to enter a password which because the touchpad has yet to become active, I'm able to do no problems.

Another pointer is when I choose to select what my boot options are, again no problem.

From these points on however, the touchpad becomes active and the keyboard acts as if it has been completely remaped. Most keys will not work and those that do are not doing their thing. EG. Pressing the 'm" key at the login screen will immediately default to " Incorrect Password " etc. Pressing any of the keys that have 'Function' stays, such as the 'Number Pad' keys, have those keys act as if that had been activated - ( no, they do not turn off using the 'FN>NumLock or Scroll Lock' combo ).

Now, after I boot and get to the logon screen ~ I then walk away until the system goes into 'Sleep' or 'Hybernation' ( Not sure which yet ) mode - I can bring the system back up and most of the keyboard works fine - I can log in and Vista appears to run fine.

I ran GMER and got to see in its' startup log that the keyboard and the touchpad are using exactly the same driver. Under Device Manager I get to see that they are also using the same Resources whereas on this Toshiba Satellite L500D I get to see that the I/O Range is different albeit that the IRQ is the same.

So, the conclusion for me at this point is that the moment the touchpad comes 'online' the keyboard is made to suffer. As said above, this system has been working fine since Vista first came out - so have no idea what has brought this on. ( Asus Live Update has NOT been installed though since I've been working on this problem I've tried it in case I missed any of the updates for Vista. Didn't help so uninstalled it again ).

Any suggestions anyone ???

( Service center personel say " Haven't seen this problem before - can't help you " )

I guess I'm after some way I can get the two hardware items forced into using different resources ???

Or is there some answer out there I've yet to find ?

2
Contributors
3
Replies
4
Views
7 Years
Discussion Span
Last Post by Biker920
0

try this go to control panel dbl click mouse click on synaptic tab disable pad click apply OK. if this doesn't work go to device manager expand mice and pointing devices right click synaptic pad disable or remove. Later---

0

Thanks for that Biker920

I've tried the second suggestion without success. The system on reboot always re-installs the PS/2 driver and the touchpad is working again.

I'll try your first suggestion, it might work for a session and allow me to get things done.

It appears that I need something that would allocate resources independently to resolve this conflict permanantly.

This system doesn't allow me to 'disconnect' the touchpad within the BIOS settings like most others do. I can live without the touchpad if that is the only way - just turning it off is a problem.

So, still looking for an answer and will try the session thing and report back.

0

Go here http://system-cleaner.comodo.com/download.html down load and install this free version of comodo system cleaner Start program go to second section click Autoruns Manager select run tab it will display all auto run items now highlite Snytpenh, in lower right corner select your preference disable or remove. close comdo and let it manage your start ups. Later---

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.