I have Windows Media Player 10 running on Windows XP with 1 Admin User and 3 Limited Users. I can play and rip from Admin, but in the Limited accounts I can only play. When I try to rip from CD I get this error:

"Windows Media Player encountered an error when reading the CD-ROM drive in digital mode. You can try to use digital mode again, or you can switch the Player to analog mode"

I then continue and change the CD drive properties to Analog but it still does not work.

If I change the Limited accounts to become full Admin then the problem goes away.

I know it's not a drive problem because the Limited users can rip successfully using RealPlayer.

Also, WMP 10 will rip from the DVD player, it's just the CD-ROM it has trouble with.

Has anyone encountered this problem and found a fix?

Many thanks,
Adrian

I don't know if this will resolve your problem, but it's the best thing I've been able to find. Click "Start", "Run...", type "regedit", and click "OK". Find the following key:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Winlogon

On the right-hand pane, you should see a value called allocatedasd. Change that value to 2, reboot the machine, and try ripping with one of the limited accounts.

Many thanks for the tip. Unfortunately this did not make any difference. However your suggestion led me down a Google path where I discovered a script that enabled me to run WMP as an Administrator. My Limited Users can now rip!

Once again, a big thankyou - without your suggestion I would not have found the solution.

FYI the RUN AS script is here: http://vlaurie.com/computers2/articles/xprunas.htm

I don't know if this will resolve your problem, but it's the best thing I've been able to find. Click "Start", "Run...", type "regedit", and click "OK". Find the following key:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Winlogon

On the right-hand pane, you should see a value called allocatedasd. Change that value to 2, reboot the machine, and try ripping with one of the limited accounts.