Hi Friend

I am having Toshiba Laptop Satellite Pro L550D model with PSLXTE serial, I have formatted the system and i installed windows 7 home premium, but my USB drive is not getting detected, I’ve checked my bios it shows USB driver is Enable. But I don’t have driver CD with me.

Pls any one can help me

Keep forcing windows 7 to update until it finds no more updates. That will most likely fix the problem but if it doesn't, try having a look for a driver on the Toshiba website.

Thanks for your reply

i have updated upto tillnow, in the USB driver port it is showing unknown port. when i plug usb data card it is showing usb is not successfully installed.

I have tried downloading all the drivers from the Toshiba Website. But no use

Is it a USB port or it it a built in card reader? Did you manage to find drivers for windows 7 for your exact laptop model on Tosiba? Toshiba have a very weird way of organizing their online support which often makes finding the right driver a real pain.

What do you use when plugging it into the USB port. A mouse, thumbdrive or other thing else. If they are old try using a new mouse and tell us whether your problem persist

I try to connect Data Card and Pen Drive

Are they old one or new one. Sometimes old one cannot work

Try doing a virus scan and tell us what you see. Have you try reformating your pen drive and plug in again to your coputer. You can reformat it using other laptop

i have done all the possible thing what are all suggest by you. the same thing is working fine in others laptop

try install windows 7 professional or ultimate... see what happens...

i have tried windows 7 professional and ultimate, but the problem is not solved

something wrong with your Motherboard....

when i connect USB it is showing unknown port

I am getting the error when ever i connect the USB drive and Data Card in windows 7 home premimum
i have enclosed an screen shot of the issue for your reference

Pls help me to solve this issue

Try reinstalling your drivers again. Something seems to be wrong with your usb port. have you reassemble any parts lately maybe adding more ram or memory?

NO, I have not done any thing what you have mentioned