0

I just installed Windows XP Pro, and I screwed something up, so I reinstalled it.

I didn't delete the first partition, I just copied the files over the old one.

NOW, when I reboot my computer, I'm forced to choose between the two, the messed up one, and the fresh one that works.

Is there any way to get rid of the old XP on my HDD, without having to start all over again, and keep the fresh one?

Thanks in advance.

7
Contributors
9
Replies
10
Views
11 Years
Discussion Span
Last Post by gerbil
0

Well, you can simply delete the old installation after you boot into your new installation.

To get rid of the choices you get...
I'm assuming you installed your old installation on C:\Windows and new on D:\Windows.
Open C:\boot.ini.
There, you will find some lines like
multi(0)\disk(0)\rdisk(0)\partition(1)\Windows="Windows XP Professional" /fastdetect....
multi(0)\disk(0)\rdisk(0)\partition(2)\Windows="Windows XP Professional" /fastdetect....

To delete the old installation choice(ie> C:\Windows), delete the line with partition(1).
Note that Drive C: will be partition(1), drive D: will be partition(2), drive E: will be partition(3) and so on. Just delete the line with the partition number corresponding to your old installation.

0

I only have a C: drive, the others are for my DVD drives and or virtua drives.

Edit:

If I go to "Run" then "MSCONFIG" I can see both boot sequences under the boot.ini tab. Can I do anything here?

0

Bump.

Fixed.

Read how here (Click)

I used the third option.

It was different with mine since I have two of the SAME opterating systems on my PC though, so I had to be very careful.

One of the versions' file had an extra "0" in it, and I figured this was the correct one since it was the second version I installed.

This is how I checked.

I went to "Run" and typed "msconfig" and then I clicked on the BOOT.INI tab. Here I could view both installations of windows, and see that one had an extra "0" (I could see this from "My Computer's" properties as well [see link]), so to be sure I set the other one as the default (you can do this here), and rebooted my PC, then I chose the TOP Windows XP Pro out of the two, and sure enough, it was the bad installation. I changed the other back to default (the one with the extra "0" in the file name), and rebooted, again choosing the TOP Windows XP Pro to boot from when prompted. Sure enough, it was the one that worked. So now I know I wanted to keep the version of XP with the extra "0" and I highlighted and backspaced the other. I also backspaced one digit (but I made sure to remember what it was) to make sure I had no spaces in between.

I rebooted and the other isn't a choice anymore, it just boots right up.

0

Bump.

Fixed.

Read how here (Click)

I used the third option.

It was different with mine since I have two of the SAME opterating systems on my PC though, so I had to be very careful.

One of the versions' file had an extra "0" in it, and I figured this was the correct one since it was the second version I installed.

This is how I checked.

I went to "Run" and typed "msconfig" and then I clicked on the BOOT.INI tab. Here I could view both installations of windows, and see that one had an extra "0" (I could see this from "My Computer's" properties as well [see link]), so to be sure I set the other one as the default (you can do this here), and rebooted my PC, then I chose the TOP Windows XP Pro out of the two, and sure enough, it was the bad installation. I changed the other back to default (the one with the extra "0" in the file name), and rebooted, again choosing the TOP Windows XP Pro to boot from when prompted. Sure enough, it was the one that worked. So now I know I wanted to keep the version of XP with the extra "0" and I highlighted and backspaced the other. I also backspaced one digit (but I made sure to remember what it was) to make sure I had no spaces in between.

I rebooted and the other isn't a choice anymore, it just boots right up.

Hi there Daddy meerkat here

I don't really understand this this!

i to have the option come up and on checking this is the code i see...

[boot loader]
timeout=20
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Home Edition" /noexecute=optin /fastdetect
signature(e9441942)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Home Edition" /noexecute=optin /fastdetect

Now I dont see any duplication there do you?

0

Hi,
The post you asked about was posted on Oct 29th, 2005, if the poster is still using Daniweb and is ever online to read your post, I doubt he will remember what happened 4 years ago.

0

I had this same problem and solved it in the easiest way possible!

I know this thread is months, if not years, old but this is the first result I found when I googled for this problem so I think a simple solution for this problem on this page is definitely useful!

Inspired by "a monkeys uncle" up above here I went into MSConfig (choose run from the start menu, type msconfig and press ok) under the BOOT.INI tab I simply clicked the "check all boot paths" button and it told me which line was no longer in use!
Then click apply, OK and reboot without having to make any choices!

Good luck!

0

1st I installed XP... running fine. then i installed Vista on the 2nd partition. Fine too. Then i removed Vista. But the annoying "Choose your operating system" stays. How to remove it? Vista OS is not recorded at all at the boot.ini (already checked). Thks

0

Could you post that actual boot.ini, ceria?
And tell us which partition it is in, which one XP is in, and where Vista was. Drive letters will do.
Also go into Disk Management [via Admin Tools, computer Mgmnt, or just go Start and Run diskmgmt.msc -and tell which partition is marked as Active, and/or System?

Edited by gerbil: n/a

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.