0

It's a common problem, there are a lot of google hits, but I could found no working solution. When I leave my computer on and don't use it, and I come back, first only the cursor works, and if I right click, that freezes too. After 1-5 min it recovers by itself.
I disabled all power saving stuff, standby mode, hibernate, everything in task scheduler, and nothing yet worked. Please if anybody found something that is working, share it here! Thanks!

5
Contributors
13
Replies
16
Views
6 Years
Discussion Span
Last Post by MoZo1
Featured Replies
  • harddrive problems can cause this ,excess heat,malware/spyware ,and many more thing . run a chkdsk /f on the drive first . ============================== Run CHKDSK to check for disk errors go to start .in the search type in cmd, right click on the cmd and choose run ass admin/ then type … Read More

  • That's weird. AFAIK if you set IDE instead of ACPI in BIOS, it would just go blue screen repeatedly till it switched to ACPI mode. That's what always happen to my friends computer when they ask to help format from XP to 7... Read More

  • I'm aware of that. When you post before, you set to ACHI and it solved it, I've been wondering, how did you able to login windows normally under IDE mode instead of ACHI? Setting to x64 would just take more RAM out but give out most of Windows capability but … Read More

1

harddrive problems can cause this ,excess heat,malware/spyware ,and many more thing .
run a chkdsk /f on the drive first .
==============================
Run CHKDSK to check for disk errors

go to start .in the search type in cmd, right click on the cmd and choose run ass admin/

then type the following text, and then press Enter:
chkdsk /f

it will say something about windows being in use , type in Y to run chkdsk next time windows restarts, then restart windows

Edited by caperjack: n/a

Votes + Comments
Hmm, what with the thumbs up sign in your avatar.
0

Problem solved, after:
- Switching my HDDs to ACPI mode in BIOS. (This also speeds them up considerably!)
- Switching power saving to S3 only in BIOS. (This one didn't help before, but I didn't reinstall that time...)
- Installing x64 win7 SP1. (Before it was x86 win7 SP0.)

You can go on and find out which helped. Please share if you did!
Thanks!

1

That's weird. AFAIK if you set IDE instead of ACPI in BIOS, it would just go blue screen repeatedly till it switched to ACPI mode. That's what always happen to my friends computer when they ask to help format from XP to 7...

0

Cause XP can't handle ACPI. Even with 7 you have to switch it on before you install 7 or else it won't install the ACPI driver and can't load if you set it later.

1

I'm aware of that. When you post before, you set to ACHI and it solved it, I've been wondering, how did you able to login windows normally under IDE mode instead of ACHI?

Setting to x64 would just take more RAM out but give out most of Windows capability but I don't think that's the root for the problem...

Votes + Comments
AHCI lol, you noticed it!
0

ACPI? ACHI? Well... each of us were wrong! xD It's AHCI! xDDD Thx for pointing it out! :)

So for the question: It's like an onboard sound card: If you have it turned off in the BIOS, the windows won't install the driver, cause it can't detect it. Now imagine you have an onboard RAID: If you turn it on, windows won't see the hard drives as it did before. But in the other hand, if you install win on RAID mode, if you turn it off, it won't see them. The trick is to set AHCI or standard IDE or RAID before you install windows, and keep it that way, so it will install the appropriate drivers and will be able to boot.
What I did exactly was that I enabled AHCI (and disabled IDE as a result), and I wasn't able to boot. So then I disabled it back, googled it, and found out, that I have to install the drivers manually, before I set it, or else they won't bee loaded at boot time, and the windows won't beet, so it won't be able to detect the "new hardware". Instead 'cause my win install was an old crap, I backed up my data, enabled it, and reinstalled a new win. This way I didn't have to mess up the drivers, and I even cleared up my old mess, while switching to x64.

About setting x64 you're officially right, but it has a great advantage: Win7 has a bug, most widely known when the network disconnects randomly. It's because there are programs like Bonjour and Chrome that messes with the network drivers (TCP stack namely). After installing these, if you reinstall the network driver (or install vmware that does this), it will install some bad stuff (randomly, not always, it's a bug after all). To fix this, you uninstall programs, reboot, delete network drivers, reboot, and let the win install it back. But not with x64, cause these programs are x86, and they will have separate stuff on a x64 system. This is the main reason I switched to x64, cause I'm experimenting with vmware, while having chrome and bonjour installed. It works.
Now, just imagine, if this bug is not restricted to the network drivers, just they are the most often reinstalled ones. You even get lot of google hits claiming this is a wifi-only bug, because wifi drivers are the most often reinstalled network drivers. This could easily be the case with my IDE drivers, causing the system hangs. Just a theory... It's up to you all to sort out which one helped, I don't have the bug anymore! :P

Here is my story, hope now you understand, and it helps. I love you all! :)

Edited by MoZo1: n/a

0

Thanks for correcting it... Even I got it wrong over time. Always got confused with ACPI, ACHI, AHCI ^^

Apparently, I have known Win XP can't run properly under AHCI so it need to be set as IDE to run properly. It also applies to Vista and Win7 that need to set as ACHI to run. During installation, yes. The main question is, when you have the 'freeze' problem, it was set to IDE right before you set it back to AHCI? Then how did you able to login to windows under IDE? I have try it numerous times but always got blue screen at win7 splash screen on both before install and after install.

I agree Win7 has this bugs for quite some time now and switching to x64 would ignore some programs that only work for x86 OS. No wonder you switch to x64 and i think it's good since most hardware now support x64 Win7 OS's unlike 2 years ago where getting drivers was a pain. And I never try to know what bonjour program is anyway. I thought it was some needed program for windows to run properly.

But it's good your problem is solved without a solution from ours. I'm sorry we couldn't provide a best solution for you right away...

0

The main question is, when you have the 'freeze' problem, it was set to IDE right before you set it back to AHCI?

- „when you had the 'freeze' problem, it was set to IDE” - Yes
- „it was set to IDE right before you set it back to AHCI?” - Yes

Then how did you able to login to windows under IDE?

WinXP doesn't have AHCI by default. But Vista and Win7 can work in IDE and AHCI too. Whichever you have at installation time, they install the drivers for at installation.
Problem only arrises if you switch it after installation: Normally you install a new hardware the way you plug it in, start windows, and then the wizard comes up. Not here, because this driver should be already loaded at boot time. So if you want to switch after installation, find the appropriate driver for a hardware you can't see, install it, and then switch.

And I never try to know what bonjour program is anyway. I thought it was some needed program for windows to run properly.

A Mac service that iTunes installs for windows too.

But it's good your problem is solved without a solution from ours. I'm sorry we couldn't provide a best solution for you right away...

Usually I can google the answer if available, or better: I already know it. If not, there is not much chance anybody can solve it remotely while I can't solve it locally. I'm satisfied if I only get new ideas to help me find it out.

Edited by MoZo1: grammar...

0

Edit:Good luck and do come back next time:)

Reason: Sorry I forget that your problem is solved.

Edited by jingda: n/a

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.