0

This issue has been bugging me since like forever! I have got two computers, which both run Windows 7 SP1, and a printer attached to one of them (the one with the printer has got Home Premium x64 and the other one has Ultimate x64, not sure that this. matters though). So yeah, what I've been trying to do is add the printer as a network printer on my Ultimate x64 Pc via Control Panel. The thing is, I can't do it as it gives me an error (Windows cannot connect to printer with error code 0x000003e3). The printer is an HP Officejet 4500 G510a-f. Now, before you post any suggestions, don't tell me to remove SP1 from the Pc with the printer, as some on the Microsoft forums have suggested, because I simply don't want to do that. I'd like a solution where I don't have to remove it. Thank you in advance.

6
Contributors
12
Replies
14
Views
4 Years
Discussion Span
Last Post by TechSupportGeek
Featured Replies
0

No, computers are not part of the same workgroup and what do you mean by specifically sharing the printer?

0

First, not sure why anyone would suggest to remove SP1. anyway, for you to connect to a shared resource whether it be a printer or a folder, you need to ensure that you have some pre-reqs in place.

1) have you validated that there is network connetivity between both computers? Can you at least ping the target computer?

2) On the computer with the printer, you have to "share" that resource. This is so that other comptuers on the local network can connect to it.

3) Ensure that any firewall applications running on the computers on the network allow this type of sharing/traffic to pass.

4) Make sure that computers on the network can resolve each other's names. This is so that when you try to connect to another computer on the network, it can find the target system.

0

There is more to it than this but this is the essential:

Things to watch for:
1) Both PC's must be on the same physical network, on the same workgroup or HomeGroup and connecting as a private network or to a homegroup

2) Both PC's must have network browsing enabled, network sharing must also be enabled on the device sharing the printer

3) The printer itself must have share enabled

4) If you don't understand any of this call a tech or a friend who knows what they are doing or study up using GOOGLE.

0

As an add-on, Most issues I have seen revolve around the network connection type. Right click network icon, select "Open Network Sharing Center" and check out the network connection type, if it is public, you have found you're main problem. Change it to private and make sure both PC's are on the same network, have same workgroup name etc....

0

here are the easy steps to get you printer to work on both PC
from the ultimate PC right click you network icon. open network and sharing. the icon that represent your network must be set to home then look for choose homegroup and sharing follow the stes to set up a home group and share files and folder. this should take care of all the sharing including the printer.if the printer is not shared go to devices and printer, right click on the printer and shoose share, got it a name you want. then go to the other pc. you can do the same step but this time just enter the paswowrd that was create for the home group on the ultimate PC, it will join the home group and the shared printer will be push to your premium PC.

0

First of all, thank you for your help, but my issue has yet to be solved. On my premium PC (the one that has the printer hooked up), a homegroup has already been created there. So what I did was to join the homegroup on my Ultimate PC. Then, when I finally tried adding the printer again, it was to no avail. Any ideas on what may be wrong? (You can be technical in your solution, I'm actually fairly computer-knowledgeable, it is just that English is not my native language)

0

In your answer you didn't mention anything about enabling sharing on the printer. This is a vital step and very easy to do. As mentioned previuosly, this option is in the context menu for the printer.

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.