0

Alright, i'm running windows me. I was having some problems playing DVDs so reinstalled direct-x. The computer then took an age to restart and when i finally got it running again my sound card seemed to have packed up. i checked in device manager and under 'Creative AudioPCI (ES1371,ES1373) (WDM) I get this under Device status:

The NTKERN.VXD, MMDEVLDR.VXD device dloader(s) for this device could not load the device driver. (COde 2.) TO fix this, click Update Driver to update the device driver.

Well, I did that and there was no profit in it. SO i clicker 'remove' in device manager and restarted so it had to redetect the device but there was no luck with that either. I tried to download the driver again and reinstall it, still nothing. The whole episode has left me irritated and upset.

2
Contributors
16
Replies
19
Views
13 Years
Discussion Span
Last Post by RagsRutherford
0

Are you using onboard audio? If so what is the make and model number of your motherboard?

Are you using an add-in soundcard? If so, what is the make and model number of your soundcard?

0

I'm afraid I'm not completely certain what onboard audio is, or the nature of my soundcard or motherboard, what's the quickest way to find that out?

0

i think i've established that the ntkern.vxd fils is the main thing not working here. the usb poert seems also to be having the same problem. how do i find out the make and model of my soundcard and motherboard?

0

i've searched my computer for the ntkern and the mmdevldr. the latter is there but the former is nowhere to be found.

0

heh heh.....

Slow down a tad, there, RagsRutherford!

If your PC has onboard sound, the speakers will be plugged into the group of connectors that are all together at rear of your PC, near your keyboard and mouse connectors. If it's an add-in card, it'll be a bit further away, in one of the 'slots' nearby.

What is the make and model number of your computer? That might help for starters.

0

ah, it's in one of the slots, then. i'm running a gateway. it says '500' on the front but i'm not sure of the make, i inherited this computer about four years ago and never bothered to check all of that stuff, regrettably.

0

Hi again Rags.

I'm not certain, but I think the driver you need to install for that Gateway/Creative soundcard is File '7510802.exe' from this dowload page:

http://support.gateway.com/support/drivers/search.asp?param=creative&st=kw

If that doesn't work, try the File '7510837.exe' as well, after you've installed the first file, as it is a 'Patch'.

If none of that works, let me know please.

Creative cards need a different driver to the included Windows ones or the Creative 'reference driver' for Gateway systems, that much I AM certain of!

0

i've tried this but i'm beggining to think it's not the driver but whatever 'pci' is - there's also a problem with the USB and the ntkern.vxd file.

0

PCI is simply the slot that the soundcard is plugged into - it's not a 'thing' installed on your system.

It sounds to me very much like you have a rather corrupted Windows install there. Have you got the installation CDs that were originally included with the system, or did you install Windows Me from your own copy?

0

i installed it from a CD that's around 300 miles away now.. i think i'm resigned to windows reinstall. resigned to using a housemates XP in fact, as i don't know where i'll get an ME from. ah well, cheers anyway.

0

perhaps if anyone has the NTKERN.VXD file they could email it to me, as it might just be that missing.

0

THe first link looks very useful but I'm afraid I can't afford to join - could you possibly give me a contraction of their solutions here?

the ntkern file is just completely absent from my computer. i downloaded one and put it in the appropriate folder which halted the system on bootup, but i deleted it in safe mode and it's running okay again, though the usb and sound card problems remail. the mmdevldr file is there so i assume there's no problem with that.

0

My apologies, Rags. I didn't realise that site was now a 'Pay for access' service. It wasn't when I became a member, and I've not been asked for a subscription payment since!

Try this Knowledge Base article:

http://support.microsoft.com/default.aspx?scid=kb;en-us;299264

The reader then added this comment:

Following the link and the instructions appears very straight forward. However....

For me I was stopped at the Startup Disk. I was able to find aspi2dos.sys in the Windows\command\ebd directory, but none of the following (asked for by the Create a Startup Disk process) were found anywhere on my system:

autoexec.ebd
comand.ebd
config.ebd
extract.ebd
fixit.ebd
himem.ebd
ramdrive.ebd
readme.ebd
setramd.ebd
winboot.ebd

There are no *.ebd files on my system.

Beyond that the trhee files I need to replace are not on the ME CD. All three are on the system in the
C:\Windows\System32\Drivers directory.

uhcd.sys
usbhub.sys
usbd.sys

Any suggestions on what is going wrong here?

Thanks.

He was then told he could obtain a startup disk with CDROM support from www.bootdisk.com and added a further comment:

Thank you again. All went well with the advice listed. Although, I believe the problem was resolved when I found that my system had two System32/Drivers directories. One was in the Windows directory, the other in the programs directory.

The latter had 80 drivers, the other had 55. I copied the missing 25 drivers to complete the driver directory in Windows/System32. Then I deleted the USB Root Hub in control panel and rebooted. All drivers came up working perfectly.

I have no idea why or how I would have ended up with two System32 directories and a partial driver directory, but that seemed to be the problem.

Thanks for the help.

I hope some of that proves useful.

0

cheers! won't be able to try that until tommorrow when i get my windows cd posted here but i'll update the results.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.