0

I work for a nonprofit in Niamey, Niger, and I'm working with a new laptop that is the only VISTA machine in my office (including the server). Although a simple ethernet cord plug-in connects every other computer (all XP) to the internet and local network, I can only gain local network access ("Local Access Only"). Unfortunately, I can't throw the machine or the operating system out the window because I'm in Niger and I don't have access to my XP CD (in the USA) and there are no Best Buys around for returns. No one in the office (including the tech guy) knows what to do with it, and it is *very* unlikely that I'll find anyone in Niamey with experience with VISTA.

I've tried deactivating ipv6 (both with that checkbox in network device properties and by changing registry bits), manually setting ip and dns addresses, removing McAffee virus scanning software, removing the Windows Firewall, and running the following command:

netsh interface tcp set global autotuninglevel=disabled

Nothing seems to be working. Any ideas?


Here are the results of my "ipconfig /all" after having disabled ipv6:

C:\>ipconfig /all
Windows IP Configuration
Host Name . . . . . . . . . . . . : MercyCorps-ntbk
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No
DNS Suffix Search List. . . . . . : company.com
Wireless LAN adapter Wireless Network Connection 2:
Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Realtek RTL8187 Wireless 802.11g 54Mbps U
SB 2.0 Network Adapter #2
Physical Address. . . . . . . . . : 00-C0-A8-E1-DB-52
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Ethernet adapter Local Area Connection:
Connection-specific DNS Suffix . : company.com
Description . . . . . . . . . . . : Marvell Yukon 88E8038 PCI-E Fast Ethernet
Controller
Physical Address. . . . . . . . . : 00-E0-B8-C6-CD-58
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IPv4 Address. . . . . . . . . . . : 192.168.1.23(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Lease Obtained. . . . . . . . . . : Friday, June 01, 2007 2:39:12 PM
Lease Expires . . . . . . . . . . : Friday, June 01, 2007 3:39:11 PM
Default Gateway . . . . . . . . . : 192.168.1.1
DHCP Server . . . . . . . . . . . : 192.168.1.1
DNS Servers . . . . . . . . . . . : 192.168.1.1
NetBIOS over Tcpip. . . . . . . . : Enabled

Here are the results of my "ipconfig /all" before disabling ipv6:

C:\Windows\system32>ipconfig /all
Windows IP Configuration
Host Name . . . . . . . . . . . . : MercyCorps-ntbk
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No
DNS Suffix Search List. . . . . . : company.com
Wireless LAN adapter Wireless Network Connection 2:
Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Realtek RTL8187 Wireless 802.11g 54Mbps U
SB 2.0 Network Adapter #2
Physical Address. . . . . . . . . : 00-C0-A8-E1-DB-52
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Ethernet adapter Local Area Connection:
Connection-specific DNS Suffix . : company.com
Description . . . . . . . . . . . : Marvell Yukon 88E8038 PCI-E Fast Ethernet
Controller
Physical Address. . . . . . . . . : 00-E0-B8-C6-CD-58
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IPv4 Address. . . . . . . . . . . : 192.168.1.23(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Lease Obtained. . . . . . . . . . : Friday, June 01, 2007 2:18:41 PM
Lease Expires . . . . . . . . . . : Friday, June 01, 2007 3:18:40 PM
Default Gateway . . . . . . . . . : 192.168.1.1
DHCP Server . . . . . . . . . . . : 192.168.1.1
DNS Servers . . . . . . . . . . . : 192.168.1.1
NetBIOS over Tcpip. . . . . . . . : Enabled
Tunnel adapter Local Area Connection* 6:
Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft ISATAP Adapter
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
Tunnel adapter Local Area Connection* 7:
Connection-specific DNS Suffix . : company.com
Description . . . . . . . . . . . : Microsoft ISATAP Adapter #2
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::5efe:192.168.1.23%18(Preferred)
Default Gateway . . . . . . . . . :
DNS Servers . . . . . . . . . . . : 192.168.1.1
NetBIOS over Tcpip. . . . . . . . : Disabled
Tunnel adapter Local Area Connection* 9:
Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
Physical Address. . . . . . . . . : 02-00-54-55-4E-01
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

I *really* wish I'd brought my copy of XP on that plane ride...

Nathan

2
Contributors
3
Replies
4
Views
10 Years
Discussion Span
Last Post by DenisOxon
0

Hi,

What do you mean by 'simple ethernet cord plugin' ?

If you have a router/switch which connects you to the internet then if you plug a Vista machine into a port then it should connect instantly.

Two suggestions

1) have you tried a different ethernet cable - maybe one you are using is faulty.

2) if using a router have you plugged into another port in case port is faulty ?

3) if you are plugging into switch/router and you are plugging into port next to uplink port, try another port. I have found that some don't work.

Hope this helps

Denis

0

Thanks, Denis!

It ended up being something completely different! I'm not much of a network guy, so I thought the DNS address given me via Windows VISTA and read online was the correct one (192.168.1.1). In the end, the router had its own IP addresses pasted on it (198.251.xxx.xxx). I entered these in manually in the IPv4 properties section in the local area network section (while disabling IPv6 via the checkbox only--although it worked by disabling ipv6 via disabling registry bits, too). Now it all works!

Now I just wish there were a way to connect to wireless networks without asking people for DNS addresses for manual configuration... For another forum... :-)

Thanks again!

Nathan

0

Hi Nathan,

Glad you got it working - thanks for letting us know.


I have never put dns addresses in when connecting via wireless networks.

If your wireless router has the the dns adddress and is issuing ip numbers, then assuming you set your pc up get get ip automatically and dns automatically, then they will on the pc when the wireless connection succedes.

Hope this makes sense - let me know if not.

Denis

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.