0

I have been using a 1GB of flash drive for over a year now with no problems and decided to get a 8G flash drive but I'm having problems with it. I
'm not sure if the flash drive its self is bad of if I can do something to make it work right.
I have windows XP and the 1Gb flash drive works in the FAT and it works great. The new flash drive when I go to reformat it says it is a FAT32. Every file I put in it gets corrupted...jpeg picture files are changed to a file that I can't open or delete unless I do a reformat. Any file I put in the new flash drive and try to open it says ...that it can't be used because part of the file is not there or couldn't be open. I tried to put a zip file, an adobe document, Microsoft word document, and a spreed sheet and all of them are way under 1 or 2 Mb except for the avi file which was about 700MB.
I have went to the properties on this flash drive and did a reformat many times and it doesn't seem to change how it work. Is there something I can do to make this work right or is this just some bad flash drive??? Thank you for any help you can give me

4
Contributors
5
Replies
6
Views
10 Years
Discussion Span
Last Post by Dinah0
0

Check your drive for viruses.
If I were you I would go to the shop where you've bought this drive and ask for changing or for testing at least.

0

Thank you Whiz.

I have AVG and Sophos on my computer and run them all the time and I just checked for virus and nothing there.
I got the flash drive from someone on ebay and everyone seem to be happy with their flash drives. Since putting up my post I just got another Flash Drive in the mail from another person on ebay and it looks as if I'm having the same problem with this Flash Drive also... so is it possible that my computer for some reason is not reading or download the files all the way on the Flash Drivewhen in Fat32 and if so why and what can be done about it. I have no problems with the 1GB Flash Drives and it is FAT with the same files or pictures.

0

This is what I get after I I put a speadsheet and a Adobe Reader file in the flash drive FAT32

"Works cannot open the file you selected. The file may be corrupted or may be a file type that the spreadsheet cannot be open. If you have a back up copy of the file, try opening that copy, or try opening the file in a program that you created it in."

The Adobe Reader file said this when trying to open "Adobe Reader could not open the pdf because it is either not a supported file type or because the files has been damaged (for example, it was sent as an email attachment and wasn't correctly decoded).

The Adobe Reader file wasn't sent in an email. It was saved to my computer

These same files I can put on the 1 GB flash drive which is a FAT and can open them time after time for the last year. So, what could be the problem when these files are saved to the 8GB flash drive FAT32???

0

Hi
I have had the same trouble and I downloaded and installed NET.Framework 1.1
And also the ' Microsoft USB Download Manager.
When I started up the manager my Flashdrive showed up as 4GB not 8Gb which it
shows when I format it FAT32 with Win XP home.
I got mine through Ebay the same as you.
Wouldn't be JINGWAYADA' by any chance.
I can transfer 4GB without any problems but once I go over it all the extra programs cant be opened.
Interesting?
I would be interested to see what you find.
Bell 122

0

With flash drives,the really piss me off.I have a USB flash drive but it got a virus.I tried formating but the virus could not leave my USB drive.I also lost my data becaue this virus attacked every file that was in the USB flash drive.Well now i learnt a lesson of making backups oftenly and i use an online backup called safecopy backup.Here am given a free 3GB un limited trial version.And they are cheap.So now i use my USB drive and well as safecopy backup

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.