0

Hello,

I am experiencing some strange behavior while using the windows XP RDP client.
we use active domain to validate all users. so when a user opens RDP to connect to a terminal server it pops up with the login screen, the user name usually appears as:
DOMAIN\username
the user then only has to type in their password to connect. However a majority of the time when the logon box comes on screen the user name is appearing as:
servername\username
since we do not use local accounts on any of the machines to validate logons, this will not allow our users to log on without first changing the username.

I have gone in and changed it through the RDP options and then saved it as the default.rdp.

i have also gone into the registry
HKEY_CURRENT_USER\Software\Microsoft\Terminal Server Client\Default\Username Hint
and changed the settings in there.

Is there some explanation for why the RDP client tries to log me in as servername\username
and is there some way to bypass that, say setting DOMAIN\username as the only login type / option?

Thank you

1
Contributor
1
Reply
2
Views
9 Years
Discussion Span
Last Post by joshua.tilson
0

Hello to any one who has actually read this and possibly wondered the same thing.

The problem is with the windows update KB 925876

RDP 6.0 has some new 'security' features, plus some others new features that are only available in Server 2008 and Vista. This changes the log on functionality of RDP from the 5.2 version.

The easy way to fix this was Add/Remove Programs, and uninstall Windows Update (KB9258766)


Just wanted to put the solution up there, for any one looking!

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.