0

I have recently noticed that I am unable to run most of the admin tools in Control Panel.

I need to run "Computer Management" to initialise a disk. When I click on the icon I get the nasty sound and a simple "Access is Denied" without further explanation.

I am the only user on this XP PC and I have Administrator rights.

I tried running it "direct" by double clicking the actual .msc file (although I don't know if that would ever work). No joy.

I am similarly unable to run :-

Component Services
Event Viewer
Dot Net Framework
Performance
Services

Although I can run :-

OBCD Data Source Administrator
Dot Net Wizards


This reminded me of a recent nightmare with a Dot Net Framework installation. I don't know/understand this, but I recall an aborted attempt to install or upgrade this caused by some other program. I probably need to clean that up too. Could that be the cause ? Any tips as to how to clean it out ?


But first I really need to be able to run Computer Management.

Help !


Regards

Graham

5
Contributors
14
Replies
15
Views
8 Years
Discussion Span
Last Post by GrahamW2
0

A virus or malware ?? You can try to restore the system using the Microsoft Restore System but only under your own risk

0

Hi jb,

I am using XP Home.

Embarasssingly I must confess that I don't understand your domain question. Given that, I guess that I am probably not on a domain. i.e. I am a normal home user with a BT DSL modem/router and a couple of PCs attached to it by ethernet cables.

Regards

Graham

0

A domain is a type of corporate windows technology where users, groups and security policy for xp pro is managed centrally by a server. As you are running XP home, this cannot be the case for you.

That means that what you are experiencing is some sort of local issue due to corruption or malware instead of an company-enforced security restriction of some kind.

try booting into safe mode (tap f8 repeatedly at bootup) and logging in as the hidden administrator called administrator. On XP home he should have no password by default. Is he able to acces the tools?

0

Thanks jb,

I tried booting into safe mode. I still couldn't run the "Computer Management" program in "Admin Tools".

I ran a full Malware Bytes scan last night - it came up with no problems.

My "gut feeling" (i.e. with no technical knowledge to back it up) is that some files were corrupted/damaged/removed when I had my tdss event recently (or perhaps it was some other culprit). I looked at the add/remove programs to see if I could "re-add" the admin tools ... no joy there.

Although I can soldier on, it is still kinda worrying that there are some (who knows how many) tools and programs which simply don't work on my PC. What next ? What if some are "important" ? Scary !

Thanks again

Graham

0

I tried booting into safe mode. I still couldn't run the "Computer Management" program in "Admin Tools".

When using the hideen account called "administrator"???? dont use your own account

If you cant even get into it as that account, then you will have to reinstall windows.

Thats the superuser account, all other rights are granted via it, and it should have full permissions on everything on the whole system. if the permissions database is so corrupt that even it is denied access, then your system is kind of dead.

0

Oh, I see. I was just loggin on in safe mode.

I've now tried switching to the "Administrator" ... same result.

It's bizarre. I only noticed this problem because I was trying to initialise a HDD in a USB caddy. I've done it before (albeit a couple of years ago) but this time I stumbled into the problem. Something must have happened in the interim. I wasn't even aware of it - my PC works in every other respect.

It hardly seem worth a complete re-install (something I've never done before). Even if I can find all my necessary CDs (and license numbers) my os goes back to 2002 ... I would have to apply all three XP service packs and countless ms security fixes (are they even all available ?). And I dread to think how many other programs I've installed over the years.

Unless there is some sort of fix to get my access back I'll just have to wait until I get a new PC :o(


Regards

Graham

0

my os goes back to 2002 ... I would have to apply all three XP service packs and countless ms security fixes (are they even all available ?

Use a tool called nlite. Install and start it up. Point at at your windows cd and choose a location to copy it to the hard drive.

Important: Select service pack ONLY in the task list. Integrate SP2, finish the whole process (dont create the .iso though) then once complete go back and do the same process again to integrate SP3. Dont try and integrate SP3 straight off. It needs SP2 first (SP2 includes SP1 which SP3 does not, because SP1 is no longer supported)

The second time round, you can also select the task to integrate hotifxes/updates and you can integrate IE7 this way. Do not try integrating media player. Also, Dont try experimenting with any of the other integration options unlessd you know what you are doing,.

if you do this you will have an almost up to date cd with the most recent release of IE and the most recent service packs. Select the task to create an .iso image file, then burn it to a cd (as an image, use a tool called deepburner free for this).

0

Wow !

Thanks for that jb, but that sounds like even more effort than "simply" re-installing from scratch (and pretty scary too !).

I was completely unaware of any problem with my system until I tried to initialise a disk in a USB caddy (as I was installing a new disk in my Sky box). I've initialised the disk elsewhere now, so that problem has gone away.

I think I'll just soldier on with my PC as it is. I am not planning on initialising any more disks any time soon.

My thought process is that I could make my PC a *little* bit better (by spending a day or so on a mega-reinstallation) or ... I could make it a LOT worse !


Don't get me wrong, I would rather that it could be fixed by running a tool or changing a setting somewhere ... but a complete reinstallation is just not worth the effort for me.

Thanks


Regards

Graham

0

you problem is cause by incorrect security entry's in the registry .usually cause by trojan or virus or malware /spyware .just search google to find correct entry's .i did have them once because i had same problem and fixed it by changing entry's ,its just a simple 1 where a zero should be .look in Local Security Policy also something may be set in there .secpol.msc in run

Soldiering on without a gun is ineffective .lol

0

Hi, I have the same problem.
I can't access admin tools in control panel.
I am using windows xp sp3 professional.
I think it's a virus, because today I can't even see the usb devices in My Computer and I tried to see them in Disk Management but in there i can't even see the main disks like C: or D:.
I can see only CD-Drives.
I think I took the virus off, but i can't see USB or Disks anymore.
So Please if anyone knows the registry files that I should change to take in control my computer.
secpol.msc doesn't work either.
I can't use System Restore cause i turn it off.
Thanks in advance

0

secpol.msc doesn't work either

If you have got XP home it wont work.

Create a new post in the Viruses and Spyware forum about your problem please.

0

Hi,

Thread starter here.

I soldiered on without "Computer Management" and the other day I stumbled upon a way to run it without going via Control Panel ... and it works.

Just right click on "My Computer" on the desktop and select "Manage". It seems that my PC is actually happy to run Computer Management after all ... just not from the Control Panel.


I hope this may help someone.

Regards

Graham

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.