0

System restore shows a blank page and sites needing javascript are saying it isnt enabled, although it is. I've looked at various previous posts regarding this topic and tried running various suggested programmes without success. Another suggestion was to download scripts from Microsoft which I have tried to do, but it is refusing to give me a validation code. I rang Tiscali support. They told me to take it to PC World! Help

4
Contributors
9
Replies
10
Views
8 Years
Discussion Span
Last Post by Starnamer
0

What Windows are you using?
Is it a pirated copy?
Is your system restore service disabled? (Under Computer management/services and applications/services)

0

Hi. I'm using Windows XP which came ready installed on my Dell. System restore isn't disabled. There seem to be a variety of suggestions reading through various forums, from reinstalling windows to using HijackThis. Just not sure where to go next.

0

I once had a similar experience with disappearing system restore service. It was deleted from my registry. Probably by a virus or some critical bug. Anyway, here are the system restore registry entries that you are probably missing. Before you merge them make sure that they are not missing from your registry:
Click Start/run
Type "regedit" (without quotes)
expand "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\Root\LEGACY_SR\0000"

It should look like this:

(Default)   REG_SZ    (value not set)
Class       REG_SZ    LegacyDriver
ClassGUID   REG_SZ    {8ECC055D-047F-11D1-A537-0000F8753ED1}
ConfigFlags REG_DWORD 0x00000000 (0)
DeviceDesc  REG_SZ    System Restore Filter Driver
Legacy      REG_DWORD 0x00000001 (1)
Service     REG_SZ    sr

Also check if the following keys exist:

"HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\Root\LEGACY_SRSERVICE\0000"
"HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\sr\Enum"
"HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\srservice\Enum"

If they are not there, merge the .reg files attached accordingly.

System Restore1.reg for the *Enum\Root\LEGACY_SR key
System Restore2.reg for the *Enum\Root\LEGACY_SRSERVICE key
System Restore3.reg for the *Services\sr key
System Restore4.reg for the *Services\srservice key

Merge No. 3 and No. 4 ONLY if they are missing from your registry.


I strongly suggest that you make a backup copy of your currently existing registry keys in question to your hard drive.
Just right-click on the following keys in the left pane:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\Root\LEGACY_SR

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\Root\LEGACY_SRSERVICE

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\sr

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\srservice

-select "export" and save it in easy to remember place, like your desktop. That is just in case this fix doesn't work.

0

Hi. When I go into the registry HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\Root\LEGACY_SR\0000 just shows 'Default) REG_SZ (value not set' with no further text. Do I assume that means theres something missing?

0

Any idea what I need to do. Would reinstalling windows work?

0

Go to C:\windows\inf, rclick sr.inf, choose Install. I don't know whether you have a cd or not, or have updated to SP3 over the web.. but you need to point the installer at the installation files. They could be on the cd [i386 folder] or in Windows\ServicePackFiles. I do not know your service pack position or Dells so cannot be exact.

0

The problem is that there is no setup CD with OEM preinstalled Windows. Only recovery DVDs. My advice is to import only those registry entries that are missing, but back up existing entries so you can undo the patching.

0

I had exactly this problem.

The solution was the command:

regsvr32 jscript

Don't know why jscript had been unregistered, but it's much simpler than fiddling with registry entries!

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.