0

hi everybody!
i'm really really looking for help for this problem i have.
it's to do with my D drive......i have a laptop so this drive is my cd/dvd.cd rom drive. i have a toshiba equium m40x running windows xp service pack 3. this morning i tried to install a new piece of software onto my laptop, while installing i got an error message telling me there was an......error at which point my laptop froze.
the only way to fix this problem was to take the battery pack out and then put it back in again, but since then my D drive doesn't recognize anything there just isn't any info in this drive/folder at all, no matter what kind of cd/disc i put in. i have tried clicking on properties/auto play and clicking on: prompt me each time to choose an action button. which results in a message coming up that says: D is not accessible...because of a I/O device error.
i've also tried uninstalling the device and restarting my laptop but nothing seems to work.
any help from anyone would really be helpful as i've been trying to fix this since this morning (uk time)
thanks

3
Contributors
8
Replies
9
Views
8 Years
Discussion Span
Last Post by Suspishio
0

thanks for your help.
but nothing seems to work.....i still get the error message.

i also tried to do a complete data recovery but even this didn't work, as i couldn't get it to start, couldn't seem to get anywhere with that, not really sure how to do that, but it might be because the D drive isn't working the way it should. any help on doing this would be appreciated.....but thanks for the help anyway.

dav

0

As I understand you, the laptop boots OK but the CD/DVD drive is unusable.

I think it's therefore safe to say that something hardware broke during the install that failed - and it's still broken.

Hopefully a USB DVD drive will still work. I don't know if the drive comes out on the Equuim like on the old Tecra I've still got; if so, replacing it is an option in the hope that nothing's wrong behind the drive.

That sort of thing.

0

hi, can you check your device manager..check the dvd/cd rom drives option..verify if its working properly..maybe just a software issue..

0

hi, can you check your device manager..check the dvd/cd rom drives option..verify if its working properly..maybe just a software issue..

yeah done all that........... it says everything is working fine.
i've uninstalled all the drivers and turned the laptop on/off and after it's reloaded windows has re-installed the drivers but it still doesn't work, still getting the error messages.
i've also heard that if you change the DMA to PIO that sometimes helps....but tried that and that also didn't help.
thanks anyway.

0

er ... and what about my suggestions?

sorry about that....
you actually gave me an idea
but first, i don't think you can put a new cd drive into the laptop.
so i just went out this morning to the local computer store( pc world) and for them to have a look at it, i would have to pay £69.
so i just went and bought myself a new external super multi dvd rewriter for £34.....so hope that should help me work around that problem.
thanks for your time anyway.

0

If my remote diagnosis is correct, it should work.

I'm gonna set up a PC store I think. So many people with problems!

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.