0

I installed backtrack 3 onto a USB flash drive. I installed it on a fat32 primary partition (sda1), gave it a 1gb swap, a ext2 storage partition (sda3), and a fat32 storage (sda4).

When I boot to windows and insert the flash drive, it shows up in My Computer, as having 1.5GB available (size of the primary partition) although it is an 8gb drive. I thought this made sense but I'm now wondering how to get windows to recognize the other fat32 partition and assign it a seperate drive letter... But I had to use qtparted in linux to partition the USB drive so I worry that windows is unable to recognize a partition table on a USB flash device. Is it possible to get windows to recognize the second partition?

2
Contributors
2
Replies
3
Views
8 Years
Discussion Span
Last Post by winrawr
0

no, but I tried using the bootit tool, and diskmgmnt, but it didn't work... I tried to just assign a drive letter and path to the fat32 partition, however diskmgmnt didn't even recognize it as a fat32 partition, and when I tried to set the drive letter it said it wouldn't work because the volume wasn't "enabled," and to enable it I had to restart my computer. Though it didn't work. Also bootit didn't make the flash drive recognized as a fixed volume. Maybe I'll try deleting and recreating the partition since I'm almost certain linux would still recognize it--I just have to transfer files out of it first.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.