I have a problem I have looked for a solution almost everywhere. I've made searches in the internet and read lots os foruns, including Microsoft's and this one. I found many posts regarding the issue, both with XP and Vista, but none really resolved or with a solution that I could use. There were originated by Symantec, but I never had it. I wanted to be sure the issue was not from the antivirus. I've spent many hours through several days searching without a result, so I'd be very happy for any useful help.

This appeared some time ago. When I try to open some programs, even very simple ones, or instal others as McAfee, I get a notice "The application failed to initialize properly (0xc000007b). Click OK to terminate the application." The program details are as the following example:
Problem signature:
Problem Event Name: APPCRASH
Application Name: [App name]
Application Version:
Application Timestamp: 486d07a2
Fault Module Name: ntdll.dll
Fault Module Version: 6.0.6001.18000
Fault Module Timestamp: 4791a7a6
Exception Code: c000007b
Exception Offset: 00009cac
OS Version: 6.0.6001.
Locale ID: 2057
Additional Information 1: 9d13
Additional Information 2: 1abee00edb3fc1158f9ad6f44f0f6be8
Additional Information 3: 9d13
Additional Information 4: 1abee00edb3fc1158f9ad6f44f0f6be8
Read our privacy statement:

Simultaneously, the icons on the start menu begun taking an extremely long time to opoen. After about 2 seconds the magnifying glass starts turning and stays like that for quite a long while. However, if I click somewhere else to close the start menu and come back they are already opened.

This issue seems to be related with the ntdll.dll file. From what I have read it is also possible to have some thing to do with the .Net Framework update whether received through Windows Update or not. I had two of these updates. However, I restored the system to a very early point; they disappeared from the list but the problem remained.

Prior to all this, as I couldn't get it straight, I searched for viruses (no viruses found, but I did have them before) and made a clean reinstallation of the OS, but the issue came back. I tried to install the antivirus today only, to be sure it was not making the issue, but this was insuccessful, as I said above. So, what is above is already after the reinstallation. This is sometging I am not able to get rid of, so I ask for help, please.

Computer specs are simple:
Windows Vista SP1 32bit
A8V-VM SE M-board
2MB Kingston Mem
Three HD: 1 Seagate and 2 Wes Digital
At the moment it has almost nothing else installed.

Hello there :)

Have you been messing around with the registry?

Could you tell me what changes you had made to the system prior to getting these errors?

Thanks for the answer.

No, I didn't touch the registery, it's a new installation and the same error happens.

All the changes I made were installing WinPatrol and onlky downloaded some windows updates. One of them, I think it was the video driver for the mboard because the display did change for better, but bewfore installation appeared the notice saying the driver was not signed and asking if I wanted to use it. I answered yes. As I did not install any driver it could be from the Windows update only. I also installed Firefoz, and that were all the changesI applied.

Do you think it can be from the .Net Framework? Onde of the many oposts I read said iy was, but there was no explication and no solution, I never found one.

Heya :)

Have you tried system restore? I'm expecting it to be a faulty automatic update.

Do you think it can be from the .Net Framework?

Could be, but like I said before, maybe a system restore will fix it.

Yes, I did restore it to a very early point, as I wrote on the second paragraph after the Microsoft link. I noticed the video driver had gone, too, but no cure for thr issue.

Yes, I did think on the NTdll possibility because it is mentioned on the eror notice, but I have no idea of what to do.

I read the page yopu suggested. I believe my case is on point 2. I am not sure about point 13 because I had lots of bad sectors on a large disk I use to save things as a "store", no OS or programs escept for a Firefox profile. I repaired them all with HDD Regenerator.

I tried with Update Checker because it is the smallest program I have (the installer is only 152KB). I unistalled, downloades a fresh installer and reinstalled. It worked! No error came up!

From what I read on your link, the issue can have several origins, so I can't say this is solved. I'll see in time and with the use. As I told you, I have not reinstalled anything yet aside Update Checker, but now, after your help and having an idea of the issue, I am going to reinstall everything, like MS Office and all the others. So I only ask you to help me further if I really need it, that is if I the issue comes back and I can't find a solution on the site you recommended.

Thank you very much. I am much more grateful for having looked for so long without a sparkle of success.

Hi :)

I'm happy that your problem is solved, if not permanently, then temporarily.

But should this occur again, I would suggest you to reformat your computer, and not just reinstall Windows.

Good luck!

Thank you so much for your help, AdarshN, but it does not seem to be solved as I thought.

It's back! I tried to use the command prompt and received cmd.exe crashed message, now not with the 0xc000007b error code, but still with ntdll.dll on the details.

Then, following the instructions of point 6 on the page of your link, I disabled Data Execution Prevention for cmd.exe and it stopped crashing if I call cmd.exe directly, but it crashes if I try to use a (not installed) little program from AMD for CPU ID which displays the information about the CPU on a command line window. The Update Checker issue was back too. Then, I rebooted as advised after the Data Execution Prevention settings. It did not boot. I used the Windows DVD to recover with System Restore. There were 3 updates, I don't know how because I hadn't turned them on yet because I was investigating the issue; they should be drievers. I took the most recent restore point and it booted again.

I'm lost and don't know whether the HD bad sectores were from the issue or the otther way round, so I left HDD Regenerator find any bad sectors iver night and cure them. This time there were 2. Before I'd find about 40.

As I have all my files in 2 other HDs, I didn't touch them. I formatted the HD with the OS/MBR where I place the OS and all programs, and then reinstalled Windows Ultimate.

Then, the issue came back. How!? Why!? Is it a NTdll problem related with hardware? Is it related with the drivers downloaded by Windows Update? Because they send me a video driver without signature and asks for permission. I can't understand why, but I have been usind the same OS on the very same computer for over a year without this issue. Could anything have gone wrong with the hardware? How can I know this? I've kept serching the web for a olution, but I can't find any.

Obviously, I am telling all this because if you don't know exactly what goes on you can't help me. And if writing is bothering, reading is fast. Thank you again for your time and help.

Hello :)

I'm so sorry to hear that it's back. Just one question before we continue, how old is this drive?

Anyways, I would be glad if you try the following :

Open up command prompt and type :

sfc /scannow

and press enter. Please wait for the program to search for corrupted dll's.
When prompted, please insert the Microsoft Windows Vista disc and wait for it to replace the files which need replacement.

Lets see what'll happen now :)

Good luck! And please DO NOT hesitate to post here, should you face any problem.

hey am new here
can anyone help me
my vista is restarting after installing alcohol 120
the blue screen and restarts only 5sec after login

Tabarak, please start a new thread. What you are doing now is hijacking this thread.

In future, please DO NOT reply in other people's threads to get YOUR problems solved.


I'm just going to say this, There is no help on how to fix this. There are a few software specifically for this. (however I cant get them to run on the computer I am currently trying to fix) however I did come across what the problem is. It's one of two things... Either a worm virus corrupted the registry or the second one (Which is the most common way this error occurs) is installing a newer software over and older version without removing (uninstalling) the older version first. You can find the software on the internet http://www.repairerrorquick.com/ttfix-0xc000007b_error-zz0001
However for windows 7 I have not found a compatible software.

Be a part of the DaniWeb community

We're a friendly, industry-focused community of developers, IT pros, digital marketers, and technology enthusiasts meeting, networking, learning, and sharing knowledge.