0

I am trying to run Vista and Windows 7 RTM via Microsof't Virtual PC 2007 and having problems with Internet Access. I have read countless suggestions to correcting this problem but they are mostly all the same suggestion, i.e. Disable the network connection and then Enable it. No matter how many times I do this the result is failure.
Let me give some facts. I have two computers running Windows XP Pro. I have installed Virtual PC SP1 on both computers and installed Vista and Windows 7 on both computers using Virtual PC. One computer works perfectly in that it does allow internet access. The other computer refuses to allow internet access and shows Local Access only. I have tried with Virtual PC Additions loaded and not loaded, I have removed all virtual machines, uninstalled Virtual PC, reinstalled Vista and Windows 7 RTM, but no matter what I do I can't get internet access. The computers are on a home network and are visible by each other but only one can actually gain access through the router to the internet.
I am not sure what it is that the software examines to determine if internet is accessible, but I have tried all I can think of. I am getting frustrated with this problem as I can't find anything obviously different between the two computers, and yet, one allows internet access and the other only gives Local Access.
If anyone has any things to try that don't involve disabling, enabling, uninstalling, reinstalling the adapter or fiddling with the IP address of the non-functioning computer (I have tried all of these items) I would be very happy to try things to get it working. I am convinced there is something somewhere (system registry perhaps?) that informs the operating system that internet access is allowed but I sure can't find what it is. I am almost to the point of reloading my whole computer, but I am not quite ready to spend the full day it takes me to get everything reloaded so any ideas would be appreciated.

2
Contributors
2
Replies
3
Views
8 Years
Discussion Span
Last Post by dnstrong
-1

Are the network adapters the same model/brand, and do you have the most suitable drivers installed on the troubled machine? You may simply be looking at a device for which never saw compatible drivers made for either Vista or Win7 (as Vista drivers would work for Win7)

0

The host computer has the correct driver for the ethernet adapter and accesses the inernet fine. The virtual machines use a Microsoft emulated driver for the ethernet adapter. The second computer is able to access the Internet uses the same version of Virtual PC 2007 with the same emulated adapter driver so that shouldn't be a problem.
Also, I installed a Windows 98 virtual machine along with the Vista and Windows 7RTM and it also cannot connect to the internet. All three VMs can access computers on the local network but none can connect to the internet. I am not sure what is wrong or missing on this computer that isn't on the other one that works properly but there must be something. My head hurts!

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.