0

I tried to get the nic on my motherboard to work and got a message that the hardware did not have a Microsoft digital signature, but I continued anyway. Ever since this attempt, I have been getting the following errors in the event viewer and my ip address is not 169.254.x.x, mask 255.255.0.0, instead of its original 192.168.1.x it got from my router.

Event Type: Warning
Event Source: Dhcp
Event Category: None
Event ID: 1006
Date: 12/31/2003
Time: 8:42:56 PM
User: N/A
Computer: MRCOLLINS
Description:
Your computer was unable to automatically configure the IP parameters for the Network Card with the network address 000C6EFA9E84. The following error occurred during configuration: The requested service provider could not be loaded or initialized. .

also i am getting about the same error, all but the last line: support for the specified socket does not exist in this address family.

I have attempted to reinstall tcp/ip, but did not make any difference. I was wondering if there was something I can do to reset winsock files like in pervious windows?

Any help would be appreciated.

Thank in advance

Michael

16
Contributors
15
Replies
27
Views
13 Years
Discussion Span
Last Post by Dani
-1

I suggest you manually assign your I.P address from the properties tab of your network adapter to use the address 192.168.0.1 if you're using that as your default gateway to enable your locally connected computers to access the internet. In the properties tab click TCP IP then click use the following IP adress 192.168.0.1 subnet mask 255.255.255.0 leave other parameters. On your localy connected computer do the same but assign differen IP i.e 192.168.0.10 subnet mask 255.255.255.0 assign the DNS no in the properties tab use this DNS no. Preffered DNS no. 192.168.0.1 Alternate DNS no. 192.168.0.1 or you can leave that blank.

0

Had similiar problem recently whilst working with a clients new Gigabyte motherboard, 2.8C CPU and Windows XP Professional. Every time Windows assigned itself an ip address I kept on getting 169.254.30.245 where it should've been a 192.168.*.* number. It didn't matter whether Zone Alarm Pro was enabled or disabled, I could see all computers in My Network Places -> View Workgroup Computers but couldn't access files on any of them.

Solution was to move the internal modem in the problematic clients' computer to another pci slot.


Hope this helps :cheesy:

0

try removingthe drivers for the network card. then reboot.
let windows find the network card, if it is win xp it might load its own drivers.
if not try to download the latest drivers from the motherboard site.

0

I tried to get the nic on my motherboard to work and got a message that the hardware did not have a Microsoft digital signature, but I continued anyway. Ever since this attempt, I have been getting the following errors in the event viewer and my ip address is not 169.254.x.x, mask 255.255.0.0, instead of its original 192.168.1.x it got from my router.

This may be a firmware problem. Some NICs have an EAROM with a default address and other information. For example, I had to download a program to reprogram the NIC to get a friend's motherboard working.

What brand & model of motherboard are we talking here?

0

I have been able to fix it most of the time by moving the Nic card around to a different PCI slot, otherwise I just put in a 192.168.....xxx...xxx address.

0

This was some helpful information. I put a 3com gigabyte nic in a Dell and plugged it to a gigabyte switch and I was getting the 169 IP address. I updated the drivers and uninstalled and reinstalled, I release and renew IP address(even though the renew errored). I finally assigned the pc a IP address with a default gateway and guess what it connected with no problems.

0

This was some helpful information. I put a 3com gigabyte nic in a Dell and plugged it to a gigabyte switch and I was getting the 169 IP address. I updated the drivers and uninstalled and reinstalled, I release and renew IP address(even though the renew errored). I finally assigned the pc a IP address with a default gateway and guess what it connected with no problems.

If the switch is a managed switch you may want to enable port fast. Spanning Tree will wait 50 seconds before allowing access to a switchport. This causes problems with DHCP. The other option is to refresh DHCP.

Windows 95/98/ME
1. Click on Start | Run

2. In the text box, type winipcfg.exe and click ok. The program will launch. In the selection box, make sure that your Ethernet adapter is selected. Basic IP information is displayed, to see an expanded view click on More Info.
3. To release and renew your IP address click the Release button. The system will pause for a moment and then click on Renew. The expanded view of winipcfg is shown, but this can be done from the normal view.

win2k
1. Click on Start | Run

2. Type cmd and click Ok

3. Type ipconfig and press the enter key, Windows will now display your information about your IP configuration
4. If you are experiencing problems with your internet connection, try to release and renew your IP address. this is accomplished by typing the following command: ipconfig /release

Remember to use a space and a front slash (the one that shares a key with the question mark). Once you have release your IP address you need to renew it by using the command: ipconfig /renew

The two commands and their output are on the right.

0

having a 169 problem, /renew usually fails saying it can't contact the DHCP server. i guess it would be better if you manually designate an IP address.

0

Hi,

My PC still doesnt work, I still get the same IP. I tried the following fixes...

1) Uncheck/Recheck QoS packet scheduler from Network connection Properties.

2) XP TCP/IP Repair

3) Winsock Fix

4) Assigning a manual IP, It connects to my internal router but not going anywhere from there (not connecting to Internet).

Its a Dell D610 Latitude, I tried uninstalling/reinstalling wireless drivers. Can anyone suggest anything I missed pls?

Thanks a lot,
Santosh.

0

I tried to get the nic on my motherboard to work and got a message that the hardware did not have a Microsoft digital signature, but I continued anyway. Ever since this attempt, I have been getting the following errors in the event viewer and my ip address is not 169.254.x.x, mask 255.255.0.0, instead of its original 192.168.1.x it got from my router.

Event Type: Warning
Event Source: Dhcp
Event Category: None
Event ID: 1006
Date: 12/31/2003
Time: 8:42:56 PM
User: N/A
Computer: MRCOLLINS
Description:
Your computer was unable to automatically configure the IP parameters for the Network Card with the network address 000C6EFA9E84. The following error occurred during configuration: The requested service provider could not be loaded or initialized. .

also i am getting about the same error, all but the last line: support for the specified socket does not exist in this address family.

I have attempted to reinstall tcp/ip, but did not make any difference. I was wondering if there was something I can do to reset winsock files like in pervious windows?

Any help would be appreciated.

Thank in advance

Michael

your problem might have occured because your device i.e nic card is not digitally verified by microsoft........to check this ..
1. go to run
2. type "sigverif"
the file signature verification Dialog box appears....if u dun see the red right tick mark ...then you should exchange ur nic card..else the cause may be different...

0

I just replaced my WAP/Router and ran into the same problem with some of the devices on my network. Namely an IPOD and an old (SP1) Windows XP system. The 169.x.x.x address is supplied when the system can't find a DHCP server - turns out that using WEP 64 caused my problem - I changed to WPA-(personal on MAC, Previously Shared Key on XP) (after checking to be sure all of my devices could use this) and voila - the IP address was correctly loaded from the DHCP Server.

Obviously, loading the ip address 169.x.x.x is much better than an indication that the DHCP server couldn't be contacted! (that was sarcastic -sorry, could't resist)

Hope this helps someone.

0

The answer can be really simple - once you figure it out. I had this problem TWICE in one week in two different locations recently. The first one cost me a full day of head-scratching.

That oddball address, which is usually a '169.254 .x.x' 255.255.0.0 address, can appear when there is an electrical connectivity problem between the PC (or other device) and the DHCP server or whatever device the PC is immediately connected to (switch, hub, etc).

The cause can be either a defective NIC, switch/hub port, patch cord or nothing more than a flakey connection for the patch cord. My solution in both cases was to simply refresh the patch cord connection on both ends (several times just to be sure I had a good physical/electrical connection).

I had numerous devices connected through the switches and none of the other devices had issues, so that narrowed the problem down to the connection between the PC and the switch port.

God, I love this stuff!

Skyhawk

4

I presume no one will read this so many years after the question was asked, but just in case someone else is looking for an answer: Look at the switch.

Spanning tree takes 30 seconds to listen and learn before forwarding. During the Listen and Learn phase, packets are not forwarded through. If you have a new PC that boots alot faster than the old one, it's possible that it gets to requesting a DHCP address faster than the switch is done with its 30 seconds of STP. If your PC does not get an answer from a DHCP server (which it would not because the switch is not yet forwarding packets), then it will assign itself a 169.x.x.x IP. To fix this, you need to enable a feature on the switch which tells it to "learn on the fly" and not block packets during that process. On Cisco switches this is called "spanning-tree portfast". Other manufacturers have equivalent commands I'm sure.

  • Ben
Votes + Comments
Thanks for sharing!
Good to know.
Excellent information.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.