0

I've been trying to play this internet game (Bejeweled 2, found at http://www.addictinggames.com/bejeweled2.html), but the game won't load in my Firefox browser. So I checked the Firefox settings, and Java was enabled and everything, and then I made sure I put the .dll files into the Firefox plugin folder, so that end was taken care of. However, it was still not working. So, I went to check out the Java settings. In the Java Control Panel, I go to Advanced, and then under "<APPLET> tag support" the "Mozilla and Netscape" box is not checked off. So I check it, and then hit "Apply", but I get this error message:

Unable to change Browser Settings
Please check that Mozilla or Netscape is properly installed on the system and/or that you have sufficient permissions to change system settings.

Now, my Firefox is properly installed and I have the latest version of Java. I'm also the administrator of this computer and I'm able to change the system settings. How do I get past this error and click the little box?

2
Contributors
3
Replies
4
Views
11 Years
Discussion Span
Last Post by antioed
0

I just posted this on Sun's site because I came across a bunch of people having the same problem. I was getting the same error when I tried to enable Java for Mozilla and this fixed the problem for me:

"Unable to change browser settings"
I was able to recreate and then solve this problem it appears many of you are having with Java on Windows XP when using Mozilla FireFox.
FireFox version: 1.0.6
XP (32bit) SP2
I had "Java plugin" version 1.4.2_05 icon in my Control Panel which seemed to be the cause of the "Unable to Change Browser settings".
I went to http://java.sun.com and let it guide me to the XP installation of Java version 1.5.0_04 and then used Sun's Java tester to verify the changes took effect: http://www.java.com/en/download/installed.jsp
I had to close all Mozilla windows and relaunch it before the tester could see the new version. I also got a different icon in my control panel simply called "Java" and with the new version I get different menus where I can enable and disable specific java plug-ins for each browser. Hope this helps.

0

I did everything you said, and the tester said that I had the latest version installed. I saw the icon in the control panel as well, but when I went back to the "<APPLET> tag support" part and clicked the Mozilla/Netscape box and tried to Apply the changes, I got the exact same error. :sad:

0

I see - actually I don't think your problem is with Java. If you go to that site in Internet Explorer it tries to load an ActiveX control. Have you checked with the site's support group? If the site needs ActiveX support in order to run I'd just use IE for the site instead of Mozilla. From what I've read Mozilla's ActiveX support isn't very reliable and you'd have to have an ActiveX control specifically designed for Mozilla and it's doubtful the site will have made multiple plug-ins...maybe a more standard Netscape platform would be supported - either way the developers of the site can say for sure. Sorry I can't help more.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.