0

Hi,
Call me stupid but I've managed to change the security settings of the C: drive on my PC in a way which denies access to this drive from all users, including me (the admin) and now I cannot access any data OR programs on this drive : these include system retore and msconfig.exe !!!

Need help urgently, cannot use my PC!!!
thanks,

dean

3
Contributors
8
Replies
9
Views
7 Years
Discussion Span
Last Post by pnky_14
0

Are you able to access Command Prompt?

If so, you can try using CACLS.exe

The syntax is CACLS pathname [options]

an example would be

C:\> cacls C:\ /P yourusername:F

**Sidenote** if your username has a space in it, you have to surround it with "quotations".

Like

C:\> cacls C:\ /P "your user name":F

Let me know if this helps

Edited by pnky_14: n/a

0

Yes, but I'm still not allowed to acces the C drive through it....

0

@pnky_4: Windows' answer is still the same : "Access Denied"...
@westdesert : I've just discovered to my horror that I can't download files now, not even on a different partition of this drive. Windows seems to think the "C: is not accessible" is a good reason for every problem...

Any last ideas before I format...

Edited by deanus: n/a

0

Hmm...to make this PC usable again, you may need to boot to Linux Live CD. I recommend Knoppix. The newest version allows you to access files and move/transfer them to a flash drive, disc, or external hard drive without changing permissions on any folder. Then you're best bet is to format the partition and reinstall the OS. Hopefully you still have the discs that came with your computer. Sorry I couldn't be of more help to you! Let me know how this ends up.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.