0

Hello,
Short Story: A file on my computer is disappearing when accessed by another user on the network.

Long Story: I have a partition on my computer (E:) that I share the root of on my work network. In the root directory, there is (was) a MapPoint file (E:/mapfile.ptm). Sometimes, when someone is using that file on a different computer and tries to save it, it shows this error:

"A file by this name already exists and is read-only or locked by some other means. In order to save it, type a different name."

However, even if you try to save as a different name or in a different location (including locally to the computer using the file), the same error comes up, and the file disappears from the file system on my computer.

This has happened multiple times. At first, I thought I had accidentally deleted the file myself. After 2 more times though, including a "now you see it, now you don't" experience today, I know it is not a user error from either party. My best guess is that restarting my computer is the root of the problem. I restarted while the file was open on the other computer, and I suppose when the other user tried to save, the file handler was confused since the network resource had been reset. I would expect this to lead to not being able to save a file, but deleting the file off of the shared drive makes no sense.

More Data:
The file was open on the other computer when I restarted my computer this morning. After the error message on attempted save, I made sure the file still existed on my machine where it belonged, and it did appear in the file list. Moments later, after attempted save-as, the file does not show in the file list in explorer.
I started playing with it after that. I restarted my computer with the file open on the other computer. If I use Windows Explorer to view the networked drive before I try to save it, it seems to work fine. How is the file being deleted when the program thinks that it can't access the file?

3
Contributors
2
Replies
3
Views
6 Years
Discussion Span
Last Post by jingda
0

Well you could try to disable file sharing first. It might have something to do with the program itself not properly save the file before and now it can't even detected files that it supported. Move the faulty files to somewhere else which not in shared directory.

0

This is a common problem, try searching use the search bar at the top to check whether is there any similar threads like yours. Does other users on other computers have the same permissions as you to edit the file?


Edit: Are you using vista? A quick check on the internet reveal that most of this problem happens to vista users. Try to disable offline files. Go and search for offline files in start and disable it. Try again.

Edited by jingda: n/a

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.