I installed Windows 8. I have write a personal script (.bat file) which worked with Windows 7 perfect. The problem on Windows 8 is:

My script executes this command:

xcopy "D:\X" "D:\E" /S /E /I /Q /H /K /O /X

xcopy is Windows's copy command.
"D:\X" is source directory
"D:\E" is destination direcotory
/S /E /I /Q /H /K /O /X are other parameters.

I got "access denied" error.

I check the properties of the directories "D:\X" and "D:\E". On the "security" tab of properties, "Authenticaed Users", "SYSTEM", "Administrators" ve "Users (computerName/Users)" all got "Full control" enabled.

I got "access denied" error even when I log on as admin. The .bat file works just when I run it as administator.

But all other users need to run this .bat file without password. It just executes something simple. Copy a file to another directory.

I will be happy if you can help me.

Thanks in advance..

Edited by Reverend Jim: fixed typo in title

4 Years
Discussion Span
Last Post by gerbil
This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.