0

My external NTFS Lacie 500GB HD hangs randomly. The disk is full of data. I have tried running Norton Disk Doctor (2005), XP's CHKDSK /f or CHKDSK /f /r from command line, or XP's GUI version of chkdsk from the disk properties. They all hang when they encounter the bad sector sometimes in phase 2 or index checking phase or phase 4. Is there anyway that I can mark the bad sector and have the disk head skip that region manually or through any software utility out there?
Additional information:
- Hard Disk is of course no longer under warranty.
- I am using XP Pro SP2
- I have tried switching between the drives USB2 and FW400 interface. They both act the same.
- Right before the HD hangs it clicks once, and the only way to get it back on is to recycle its power.

Thanks,
Daniel Motamed

3
Contributors
6
Replies
7
Views
11 Years
Discussion Span
Last Post by motamedd
0

Check LaCie's support site; most drive manufacturers have downloadable low-level disk diagnostic & repair utilities for their products.

0

I emailed LACIE Tech Support, but they were not much help. Low level format is not an option, since my half terrabyte of data is very improtant to me (family video and pictures).


I have tried the Spinrite 6.0 which does the same thing as the HDD Regenerator and attempts to fix magnetic disk errors that are cause of bad sector. Unfortunately both these software run at DOS level and are geared toward internal PC drives. I only have access to laptops and removing the USB drive from its shell and connecting it to the IDE of a PC is not readily an available option for me.

I could not find any BIOS setting that would turn USB on in my Sony Vaio GRT270P. So I have been trying to get USB2 driver loaded at the DOS level in the same boot CD or floppy that the regenerator software gets loaded to. After many trials I have not been able to make it work yet. Here is what I am putting in the config.sys, but it is not working for me:

DOS=HIGH,UMB
LASTDRIVE=Z
DEVICE=HIMEM.SYS
REM not sure if the above lines are required, but Spinrite does not like it as it complains about low memory. I have tried remming them out, w no effect.
REM The following line loads Panasonic's universal USB- controller driver
DEVICEHIGH=USBASPI.SYS /v /w /e
REM the following is an aspi mass storage driver for usb- connected HDs and compactflash memory cards. This does not find the LACIE external USB HDD.
DEVICEHIGH=DI1000DD.SYS
REM the following is the XP USB 2 driver for LACIE external drives- Not sure if it is the right one for DOS. Can’t tell if it is correct since I could not get past the low memory problem.
DEVICEHIGH=TPP300.SYS
REM The following loads CD-ROM driver but I have not activated it since the internal CDROM drive is detected without it.
REM DEVICEHIGH=USBCD.SYS /d:USBCD001

Can anyone help with the config.sys?

0

Er...motamedd indicated that Spinrite was already tried:

I have tried the Spinrite 6.0...

0

No Problem... I encourage any remaining ideas to try loading the DOS level drivers for USB2 or FW400.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.