0

Hi, here is my problem.

I play world of warcraft on a Sony PCG-FRV26 Laptop, it has a Radeon IGP 345M Graphics Card Driver. With this Driver, WoW is scratchy and buggy and is not very good (graphically speaking). But I came accross a thread one night about a guy who had the same laptop and same drivers, and he found a way to fix it.

By downloading Radeon Omega Drivers! Exactly: Radeon IGP 34xM (Omega 3.8.291) and when I installed it it worked! I had great framerate, the graphics improved dramatically, I was soo happy.\

But then, 2 months ago, I had a horrible virus, had to wipe my computer clean, order in from Sony the Driver CD and everything, installed WoW again and my Comp had the IGP 345M Drivers, so it was scratchy and not good aat all. I went to the site, downloaded the Omega Drivers, did everything the same, but this time it didn't work!

When I finished it, restarted windows, when I started to run WoW, before it even opened it said "World of Warcraft was unable to start up Direct3D acceleration. Please make sure DirectX 9.0c is installed and your video card drivers are up to date."

So I went into dxdiag, looked in Display and there was:
DirectDraw Acceleration: Not Available
Direct3D Acceleration: Not Available
AGP Texture Acceleration: Not Available
and the buttons on all of them were disabled and I couldn't enable them as some other websites say...

Can someone help me please I don't want to go back to my old drivers there horrible!

2
Contributors
3
Replies
4
Views
10 Years
Discussion Span
Last Post by sanjeevmalhotra
0

follow these steps
1. start>run>dxdiag>display or display1>Note how much video memory is on the Approx. Total Memory line under Device
2.start>control panel>display>settings>advanced tab>troubleshoot>clear the Enable Write Combining check box>ok
3.disable 3d accleration and try to enable it again
4 look for updated driver for the display adapter

0

Also try to disable any firewall or antivirus that you have and then try the above steps for that you can use following steps
1 start> run>msconfig
2. select selective startup
3. uncheck load startup items
4. in services tab hide all microsoft services and disable all third party services
5. click apply and close and restart the computer
6. Now try all the steps
if the issue is resolved dont forget to select the normal mode once again from msconfig

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.