0

I'm using Windows XP.

I got a new flash disk and I used it outside in an internet cafe. When I got home, there was this weird file that suddenly popped out so I supposed that it was a virus or some malicious file because I haven't seen it before. The filename was AUTORUN, I think the extension was .dll. Anyway, I deleted it.

Now when I open my computer, and double click on the icon for drive C, nothing happens. I can still open the other folders (like the documents folder of my sister etc..) and the drive A, and also drive H (for the cd) but if I want to open drive C, I still have to right-click and choose explore.

Is there a way to fix things so I could make the "double-click to open" still work for drive C?

Thanks to anyone who'll help. :cheesy:

20
Contributors
35
Replies
36
Views
10 Years
Discussion Span
Last Post by lappoo
0

This sounds like the baddie program altered the registry to run itself.

There might be other solutions, but a reinstall of Windows should fix it.

0

Well, aside from that weird thing, nothing else has happened. I'll just take your advice but ask someone older, maybe my neighbor, to do it. Now I'm scared to touch the pc. hehe.. But thanks so much for the reply.

0

try this

RESOLUTION
WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

To resolve this problem, edit the registry to set the value data for the Default string value in the registry keys that are described in the "Cause" section of this article to none:
1.Start Registry Editor (Regedt32.exe).
2.Locate and then click the Default value under the following keys in the registry if this problem occurs with folders:
HKEY_CLASSES_ROOT\Directory\shell
If this problem occurs with drives:
HKEY_CLASSES_ROOT\Drive\shell
3.Click Modify on the Edit menu.
4.Type none in the Value data box, and then click OK.
5.Quit Registry Editor.

0

If you want, you could try to make a shortcut of the c drive on your desktop.

Do this:

right click ondesktop| go to new | go to shortcut | type "C:" | click next | click finish

Then you should be able to just double click that. But you can't put the shortcut in My Computer, but you could just leave it on your desktop and double click that. Other than that, I would suggest a windows reinstall, whcih is always good.

0

No need to Isnatll Widnows again , there is a simple solution just open Notepad and save it with the name "autorun.inf". copy this file to all drives that are nto opening on double click. when u will try to copy the File it will ask to replace the older file click "YES". Then restart your pc. hope you will nto face this problem again.

0

Hello there all having problem "can't open portable/fixed drives with double-click"

Here is a simple solution.

1.Create a new text file and rename it as "autorun.inf".
2.Copy following code to the file and save it.
Code:(check attached image for assistance)

[AutoRun]
open=C:\windows\explorer.exe

Copy this file to all drives and you are done.

Unmount flash drive,and insert it again.

Now when you will double-click any drive,it will simply open without any "open with..."dialog.

Have fun.

Babar Jahangir,Islamabad,Pakistan

Attachments Autorun.JPG 15.59 KB
0

Bushii...your advice works mate. Simple as ABC. Sceptic at 1st but hey presto..it works right after i restart my comp. Thanks a million mate.

0

Hi, my problem is almost all normal folder (folder that i create myself) couldn't be opened using double-click. Others like My Docs, My Comp, behave normally. What is wrong here and how to fix it? Thanks in advance!!!!

0

Oppss....I should've elaborate more. Whenever i double-clicked these folder, nothing came up. When I right-clicked, the first option is ' enqeue this file in winamp' instead of 'open' or 'explore'. I suspected this started when I updated my VLC player to the latest version because when I tried to open a folder recently, it automatically open VLC player and try to play the file with it (even with a non-audio or video files!). So I tried uninstalled and re-installed the player and adjust some of the file association with VLC but nothing change for the double-clicking action. I haven't try system restore yet coz I hope I could find solutions from this forum first. So, I hope somebody could help me with this problem. Thanks!

0

Hi Dream your problem is slightly different to theres what it sounds like to me is your problem is when you double click these files/folders they automatically open in your music video player is that correct? if thats the cast then when you reinstalled your new version of the program there would of been a little tick box ticked saying "always use selected program to open this kind of file" so to fix that right click on that kind of file and hit open with and then select the desire program to open your files.

I hope that makes sense.

0

Hi Dream your problem is slightly different to theres what it sounds like to me is your problem is when you double click these files/folders they automatically open in your music video player is that correct? if thats the cast then when you reinstalled your new version of the program there would of been a little tick box ticked saying "always use selected program to open this kind of file" so to fix that right click on that kind of file and hit open with and then select the desire program to open your files.

I hope that makes sense.

That does make sense and it also reminded me that i forgot one more thing (LOL!). Whenever I right clicked the folder normally there would also be an 'open with' option, right? But it was nowhere to be found now. So, what do I do???

0

That does make sense and it also reminded me that i forgot one more thing (LOL!). Whenever I right clicked the folder normally there would also be an 'open with' option, right? But it was nowhere to be found now. So, what do I do???

it usually goes "open, edit, new, Print, Open with" starting from the top if there is no open/open with there might be a bigger problem at hand whats the program you recently downloaded called?

0

I think it's VLC player because before this in addition to the lost of 'open with' option, whenever I double-clicked a folder, it automatically opened with VLC. So I uninstall VLC and re-install it but this time I modified a little bit the file association (before this I didn't) so now it doesn't open with VLC anymore. The folders just doesn't open anymore on itself.

0

Hi Dream,use included VB Script to make folders open on double click

>>
'folder_open.vbs - Fixes problem where Search opens on a double click
'© Doug Knox - 03/13/2002
'Downloaded from www.dougknox.com

Set WshShell = WScript.CreateObject("WScript.Shell")

p1 = "HKEY_CLASSES_ROOT\Directory\shell\"
p2 = "none"

WshShell.RegWrite p1, p2

p1 = "HKEY_CLASSES_ROOT\Drive\shell\"
WshShell.RegWrite p1, p2

X = WshShell.Run("REGSVR32 /I /S SHELL32.DLL",4,True)
Set WshShell = Nothing

MyBox = MsgBox("Folders will now Open when double clicked", 4096, "Finished!")
<<

Use Notepad or any other editor to save this file as FoldrOpen.vbs


Regards

Babar Jahangir,Islamabad,Pakistan

0

Hi Dream,use included VB Script to make folders open on double click

>>
'folder_open.vbs - Fixes problem where Search opens on a double click
'© Doug Knox - 03/13/2002
'Downloaded from www.dougknox.com

Set WshShell = WScript.CreateObject("WScript.Shell")

p1 = "HKEY_CLASSES_ROOT\Directory\shell\"
p2 = "none"

WshShell.RegWrite p1, p2

p1 = "HKEY_CLASSES_ROOT\Drive\shell\"
WshShell.RegWrite p1, p2

X = WshShell.Run("REGSVR32 /I /S SHELL32.DLL",4,True)
Set WshShell = Nothing

MyBox = MsgBox("Folders will now Open when double clicked", 4096, "Finished!")
<<

Use Notepad or any other editor to save this file as FoldrOpen.vbs


Regards

Babar Jahangir,Islamabad,Pakistan

Could you elaborate more? I didn't really understand this and afraid might get it wrong. Plus, I'm not that good at tech thingy majiggy...lol!

0

Use my methods. It does the same thing but its all typed out for you, all you need to do is unzip then right click and select merge for each .reg file

0

Use my methods. It does the same thing but its all typed out for you, all you need to do is unzip then right click and select merge for each .reg file

YAY!!!!!! My problem solved! You're the man (or woman?) ! Thanks a lot for helping me and thanks to others who pay attention to my prob too.....

0

:) u welcome.

theres a dialog box appeares "application not found" every time i double click the microsoft word,, and the microsoft office as well.. pls. help me..

0

bushii, thanks alot you solve my problem but i have 1 more question, i can't open any application on my microsoft office and any of the saved gemes?
i wish you could help me on this matter. theres a dialog box appeares "application not found" every time i double click the microsoft word, as well as the games

0

here's the solution, it worked for me...
http://www.mydigitallife.info/2007/04/19/unable-to-open-hard-or-usb-flash-drive-with-windows-script-host-cannot-find-script-file-autorunvbs-error/

To correct and solve this error, follow this steps:

Run Task Manager (Ctrl-Alt-Del or right click on Taskbar)
Stop wscript.exe process if available by highlighting the process name and clicking End Process.
Then terminate explorer.exe process.
In Task Manager, click on File -> New Task (Run…).
Type “cmd” (without quotes) into the Open text box and click OK.
Type the following command one by one followed by hitting Enter key:
del c:\autorun.* /f /s /q /a
del d:\autorun.* /f /s /q /a
del e:\autorun.* /f /s /q /a

c, d, e each represents drive letters on Windows system. If there are more drives or partitions available, continue to command by altering to other drive letter. Note that you must also clean the autorun files from USB flash drive or portable hard disk as the external drive may also be infected.

In Task Manager, click on File -> New Task (Run…).
Type “regedit” (without quotes) into the Open text box and click OK.
Navigate to the following registry key:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

Check if the value name and value data for the key is correct (the value data of userint.exe include the path which may be different than C drive, which is also valid, note also the comma which is also needed):
“Userinit”=”C:\WINDOWS\system32\userinit.exe,”

If the value is incorrent, modify it to the valid value data.

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.