0

Every time I reboot my XP machine the quick launch disappears and I need to manually replace it. I have read other forum threads on this matter but not found a solution. I have noticed that the desktop.ini file is there, however, when I run a search for desktop.ini on the whole system search only finds 3 instances of the file (and not the one in the quick launch folder) Are there any easy solutions for this issue?
Recently, I have been running Ad-aware, CWShredder, and Spybot to try and eliminate pop-ups and the garbage that collects over time.

32
Contributors
51
Replies
55
Views
12 Years
Discussion Span
Last Post by tazogamer
0

Do a thorough Windows Update first. Start IE. Go to Tools, then Windows Update.

Sound very much like a pre-SP1 problem.

0

This might help
Quick Launch - Missing or you receive an error message, to correct:

This behavior can occur if the Quick Launch folder has been deleted. To resolve this issue, recreate the Quick Launch folder. Create a folder named Quick Launch at the following location:

C:\Documents and Settings\Application Data\Microsoft\Internet Explorer

Also this .
http://www.kellys-korner-xp.com/taskbarplus!.htm

0

There are two forms of the Quick Launch error:

1) After every reboot, you have to manually restart Quick Launch, or
2) when you try to activate Quick Launch, you get a "Cannot create toolbar..." error.

If you are encountering problem #1 above, then do the following:

1. In Registry Editor (Start > Run... > regedit), navigate to:
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Winlogon

2. Find the "Userinit" key
3. it probably contains:

%system32%\wsaupdater.exe,

where %system32% represents the path to the System32 folder. For example, C:\Windows\System32

4. Instead of wsaupdater.exe, the data should contain userinit.exe,. Using the example above, change it to:

C:\Windows\System32\userinit.exe,

Do not forget to add the comma at the end!!!

5. Close the Registry Editor and reboot your computer.

0

Jacko2215 - that is exactly what needed to be done! Thankyou for your help!

0

After reading through these (and many other similar forums) and not finding a solution that worked for me, there appears to be a 3rd form of the problem 'Quick Launch disappears each reboot' which I was able to fix as follows:

1) Run 'Regedit'. Browse to the following registry location: HKEY_CURRENT_USER\software\microsoft\windows\currentverion\polices\explorer

2) Locate the Registry entry 'NoSaveSettings'and double-click to bring up the 'Edit DWORD value' diaglog

3) Change the 'Value Data' from '1' to '0' (i.e. where 0 = Explorer Settings - including Quick Launch Settings - are saved)

4) Close Regedit

5) Restart the Computer

6) Ensure that the Quick Launch Toolbar is displayed (Right-click anywhere on the toolbar to bring properties and check 'Show Quick Launch Toolbar'.

7) Restart the Computer

Note: The 2 restarts are necessary in order to actually see the changed behaviour. The first restart saves the registry change so that Explorer settings (such as Quick Launch settings) are saved during the second and all subsequent restarts.

0

I was having this same problem, but I thought that Windows just had reconfigured it that way.....

0

I have checked the regedit and all the values were set as they show in above answers,

C:\Windows\System32\userinit.exe,
and
0 in policies already there

Still the quicklaunch check in settings for taskbar disappears every time I boot up.
Help! I have windows XP

0

I Have tried both the guides here and no luck.
It already says C:\Windows\system32.userinit.exe, but the quicklaunch is gone anyway...=/
And in the other guide (Correz guide), the specified key asked for doesnt even exists...

There must be something else wrong. :sad:

Help please!

0

No, i haven´t. I dont want to use that way...if possible another way.?

But I haven´t found any...=/

Soor i don't. if you go here [C:\Documents and Settings\Application Data\Microsoft\Internet Explorer]is there a quick taunch folder
I fixed mine once with that method ,that why i suggested it .!

0

Soor i don't. if you go here [C:\Documents and Settings\Application Data\Microsoft\Internet Explorer]is there a quick taunch folder
I fixed mine once with that method ,that why i suggested it .!

The Quick launch folder is there with all the icons inside...

0

The Quick launch folder is there with all the icons inside...

here is what i would do ,move the folder and its content from here ,[C:\Documents and Settings\Application Data\Microsoft\Internet Explorer]to your desktop .then create a new folder in ithe nternet explore folder ,call it Quick Launch ,uncheck quick launch from the tool bar .reboot computer ,then copy the content of the old quick launch folder you moved to the desktop ,to the new folder you created ,and turn the quick launch back on .
To turn off and on quick launch .right click the lower bar ,go to toolbars and check off quick launch .
if thats confusing ,let me know .

0

here is what i would do ,move the folder and its content from here ,[C:\Documents and Settings\Application Data\Microsoft\Internet Explorer]to your desktop .then create a new folder in ithe nternet explore folder ,call it Quick Launch ,uncheck quick launch from the tool bar .reboot computer ,then copy the content of the old quick launch folder you moved to the desktop ,to the new folder you created ,and turn the quick launch back on .
To turn off and on quick launch .right click the lower bar ,go to toolbars and check off quick launch .
if thats confusing ,let me know .

I think I did as you said...but i disappears each reboot anyway...
To be sure, can you describe it in more detail please?

0

sorry ,no luck ,what about a system restor back to before it all started !

The only problem is that my system restore was created when I didnt have any quick launch bar =P...

I will probebly have to reinstall windows, but I might as well install XP from scratch on my computer, that way all adware and shit will diseppear to...
I dont really trust on Ad-Aware SE Personal, because another time it found som infected stuff and I deleated them, and after that I couldn´t log in anymore. :)
So I am a litte afraid of deleting stuff in there after that incident...

0

My fix to the Quick Launch required adding another changed setting to my regedit. Thanks to Correz for getting me started in the right direction.

For those of you still having trouble after follow the other options. I would like to offer up an additional registry key that I found to fix my problem.
Correz fix involved one registry key, mine offers two keys.

HKEY_Current_User\software\microsoft\windows\currentversion\policies\explorer
change the NoSaveSettings value to "0"

KKEY_Local_Machine\software\microsoft\windows\currentversion\policies\explorer
Change this setting also to NoSaveSettings value to "0"

Close Regedit/restart the computer/ ensure that the Quick Launch Toolbar is ticked via right click on taskbar/toolbar/tick quick launch.
Restart the computer a second time!!!

Thanks so much to Correz for getting me started on this fix and I hope that the second added tweak in regedit helps a few of you also!

First time post here, sorry for spelling errors or if my format
isn't the best........kinda nervous, why I don't understand. lol

Rainna

0

here is what i would do ,move the folder and its content from here ,[C:\Documents and Settings\Application Data\Microsoft\Internet Explorer]to your desktop .then create a new folder in ithe nternet explore folder ,call it Quick Launch ,uncheck quick launch from the tool bar .reboot computer ,then copy the content of the old quick launch folder you moved to the desktop ,to the new folder you created ,and turn the quick launch back on .
To turn off and on quick launch .right click the lower bar ,go to toolbars and check off quick launch .
if thats confusing ,let me know .

what worked for me was:
cut and paste the quick launch folder to the desktop,
reboot....
cut and paste quick launch folder from the desktop back to c/documents and settings/owner/aplication data/microsoft/internet explorer/
right click on taskbar....
check "quicklaunch"
Reboot
Ta Dah! (hopefully)
this worked for me

0

After reading through these (and many other similar forums) and not finding a solution that worked for me, there appears to be a 3rd form of the problem 'Quick Launch disappears each reboot' which I was able to fix as follows:

1) Run 'Regedit'. Browse to the following registry location: HKEY_CURRENT_USER\software\microsoft\windows\currentverion\polices\explorer

2) Locate the Registry entry 'NoSaveSettings'and double-click to bring up the 'Edit DWORD value' diaglog

3) Change the 'Value Data' from '1' to '0' (i.e. where 0 = Explorer Settings - including Quick Launch Settings - are saved)

4) Close Regedit

5) Restart the Computer

6) Ensure that the Quick Launch Toolbar is displayed (Right-click anywhere on the toolbar to bring properties and check 'Show Quick Launch Toolbar'.

7) Restart the Computer

Hey there.... first post post here....
Thanks to Correz for the fix. It worked on my computer just great. I just wanted to add that my computer did not have the problem with the Quicklaunch disapperaing until I used Webroot's Windowwasher 5.5! I checked out the settings in windows washer, but nothing would explain that post cleaning behavior. Anyway just wondering how may folks with this problem also have windows cleaner installed.

0

donniebgood here;
I've tried everyone of the fixes listed here but no luck. Either the value already existed as suggested or the proper userinit.exe, was already there or cutting and pasting Quick Launch folder to desktop, rebooting and pasting folder back into Internet Explorer folder @ c;/ failed also. I run AVG anti-virus, Advanced Windows Care, Ad- Aware SE, Spy Bot, Spyware Blaster, Bazooka Spyware scanner and Zone Alarm. Nothing detected. Looked for but found no Windows Automatic Update downloaded for the week before the problem started, (11.29.06). Tried several System Restore Points with no luck. When I check my Quick Launch Folder @ c:/user/documents, you get the picture, all of my special folders and icons are there. Have not downloaded any new software in the previous couple of days.

0

donniebgood here;
I've tried everyone of the fixes listed here but no luck. Either the value already existed as suggested or the proper userinit.exe, was already there or cutting and pasting Quick Launch folder to desktop, rebooting and pasting folder back into Internet Explorer folder @ c;/ failed also. I run AVG anti-virus, Advanced Windows Care, Ad- Aware SE, Spy Bot, Spyware Blaster, Bazooka Spyware scanner and Zone Alarm. Nothing detected. Looked for but found no Windows Automatic Update downloaded for the week before the problem started, (11.29.06). Tried several System Restore Points with no luck. When I check my Quick Launch Folder @ c:/user/documents, you get the picture, all of my special folders and icons are there. Have not downloaded any new software in the previous couple of days.

I'm having the exact same problem. Tried everything suggested, still Quick Launch doesn't appear after rebooting. I have to click it on everytime I start the computer. :confused:

0

After reading through these (and many other similar forums) and not finding a solution that worked for me, there appears to be a 3rd form of the problem 'Quick Launch disappears each reboot' which I was able to fix as follows:

1) Run 'Regedit'. Browse to the following registry location: HKEY_CURRENT_USER\software\microsoft\windows\currentverion\polices\explorer

2) Locate the Registry entry 'NoSaveSettings'and double-click to bring up the 'Edit DWORD value' diaglog

3) Change the 'Value Data' from '1' to '0' (i.e. where 0 = Explorer Settings - including Quick Launch Settings - are saved)

4) Close Regedit

5) Restart the Computer

6) Ensure that the Quick Launch Toolbar is displayed (Right-click anywhere on the toolbar to bring properties and check 'Show Quick Launch Toolbar'.

7) Restart the Computer

Note: The 2 restarts are necessary in order to actually see the changed behaviour. The first restart saves the registry change so that Explorer settings (such as Quick Launch settings) are saved during the second and all subsequent restarts.

This worked for us, very quick and easy. I'm just wondering, how do you know this?

0

After reading through these (and many other similar forums) and not finding a solution that worked for me, there appears to be a 3rd form of the problem 'Quick Launch disappears each reboot' which I was able to fix as follows:

1) Run 'Regedit'. Browse to the following registry location: HKEY_CURRENT_USER\software\microsoft\windows\currentverion\polices\explorer

2) Locate the Registry entry 'NoSaveSettings'and double-click to bring up the 'Edit DWORD value' diaglog

3) Change the 'Value Data' from '1' to '0' (i.e. where 0 = Explorer Settings - including Quick Launch Settings - are saved)

4) Close Regedit

5) Restart the Computer

6) Ensure that the Quick Launch Toolbar is displayed (Right-click anywhere on the toolbar to bring properties and check 'Show Quick Launch Toolbar'.

7) Restart the Computer

Note: The 2 restarts are necessary in order to actually see the changed behaviour. The first restart saves the registry change so that Explorer settings (such as Quick Launch settings) are saved during the second and all subsequent restarts.

I did the above but in the explorer folder there was no Registry entry called "NoSaveSettings". There was a "Default" and a "NoDriveTypeAutoRun". What happens now?

0

I did the above but in the explorer folder there was no Registry entry called "NoSaveSettings". There was a "Default" and a "NoDriveTypeAutoRun". What happens now?

0

Herein where my problem may lie. .... Policies, Explorer ..... all I have in the name column are
Defult:
LinkResolveIgnore : value is 0
NoDriveTypeAutoRun: that one has a value of 91 ? :-/

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.