0

Hi errbody!:confused:
I got a problem with my PC:icon_sad: . Since last week, I can't disabled/enabled my system restore, suddenly, the place I've to click it grey and it's write: "Disabled by Group Policy":-/ , I've tried to Run "gpedit.msc" to see what the matter but it doesn't work:icon_rolleyes: . Is there someone who can help me???:icon_cry: Please and thanks for your answer.

6
Contributors
16
Replies
17
Views
10 Years
Discussion Span
Last Post by trezuresnheven
0

also right click on "my computer" and choose manage. go into services and check that the system restore service is started and set to automatic

0

Hey

Are you using XP Home Ed? You can't use any of the useful *.msc apps of XP Pro on the poorer relation. If you are running XP Pro, and gpedit is missing from c:\windows\system32 then maybe a repair, or "chkdsk" (in recovery console) is the best idea.

I assume this is a home PC, not on a Domain, because Domain policy could overwrite.

That leaves you I think with the registry. I searched for the registry key for this here but, MS don't advise changing DisableSR.

Here is some more info on the DisableSR.

Hope this is of some help, regards, Dave.

0

Just saw this if it helps

Starting System Restore From a Command Prompt in Windows XP
1. Restart your computer or turn the computer on
2. Start tapping the F8 key. The Windows Advanced Options Menu appears. If you begin tapping the F8 key too soon, some computers display a "keyboard error" message. To resolve this, restart the computer and try again.
3. Select the "Safe Mode with Command Prompt option" and press Enter
4. Log on to the computer with an administrator account
5. Type the following at the command prompt and press Enter
%systemroot%\system32\restore\rstrui.exe
6. Follow the onscreen instructions to restore your computer to an earlier time.

And if you get gpedit working....


Re-enabling System Restore in Windows XP via the Group Policy Editor
In some cases, System Restore is disabled via the Group Policy Editor. In these cases, System Restore does not show up as a tab under My Computer Properties in Windows XP. If it doesnt show up, the question becomes how do you turn it on in the first place. To re-enable System Restore via the Group Policy Editor, follow these directions:
1) Start the Group Policy Editor by clicking on Start, Run and typing gpedit.msc in the Run box and pressing Enter
2) In the left hand column, click on Computer Configuration, Administrative Templates, System, System Restore
3) In the right hand column, set Turn off System Restore and Turn off Configuration to Disable
4) Minimize the Group Policy Editor
5) Right click on My Computer and Select Manage
6) In the right hand column, double click on Services and Applications, then Services
7) Find the System Restore Service and double-click to open
8) On the General tab set [Startup Type] to Automatic using the drop down list
9) Click the Start button to start the service
10) Close the Computer Management console
11) Maximize the Group Policy Editor and set Turn off System Restore and Turn off Configuration to Not Configured
12) Close Group Policy Editor and reboot the system.
13) Once the system is rebooted, Click on Start, Right-click on My Computer, click on Properties and the System Restore tab should appear again.

From

http://www.pchell.com/virus/systemrestore.shtml

0

Hi!!!
I've tried to do what you told me but it also doesn't work. So don't you have another suggestion???:-/

0

Thanks, DaveB, I went to a command prompt under safe mode and
I was still rejected with the message:
"System Restore turned off by Group policy."


And if you get gpedit working....

I tried Gpedit but there was no System Restore under System.

Would you have any other suggestions?

Thanks.

0

My turn. Betcha don't got enough space on your sys drive to make a restore point? That little matter will automatically disable System Restore. Well, it could be an answer.... although I imagine it is only a problem for those with multiple partitions, and who have made C: too small...

0

My C drive has a total of 11 GB with 51 used.
Thanks for the suggestion.

I have received one good tip to fix it but it involves
deleting a key in the registry. I am a bit nervous
about changing the registry because if I screw it up I may not be able to restart the system.

0

Just as well i didn't put money on it.. :). This the key?:
HKEY_LOCAL_MACHINE\Software\Microsoft\WindowsNT\CurrentVersion\SystemRestore
"DisableSR" = 0
That one? You could check if it is set to zero as I have shown - if is one then set it back to zero [default].

0

****************************************************************

I believe some hacker or virus got into my computer and screwed up a number of things including disabling
System Restore.

I am using MS XP professional.

I FINALLY was able to fix the problem.

I will go through a number of suggestions and the results.

********************************
SUGGESTION 1

Start>Run>regedit>OK

Now navigate to the following location:-

HKLM\Software\Policies\Microso­ft\Windows NT\SystemRestore

Click on 'SystemRestore' and in the right pane find entry "DisableSR", right click on it and delete it.

Close the registry editor and restart the system.

RESULT: IT DIDN'T BRING BACK SYSTEM RESTORE.

***********************************************


***************************************************
SUGGESTION 2

To enable or disable System Restore, perform the following steps:

1. Start the System Control Panel applet (go to Start, Settings, Control Panel, System).
2. Select the System Restore tab.
THERE IS NO SYSTEM RESTORE TAB UNDER SERVICE

******************************************************************
SUGGESTION 3

I went to a command prompt under safe mode and
I was still rejected with the message:
"System Restore turned off by Group policy."


*****************************************************************
SUGGESTION 4

An alternative to the usual method of enabling and disabling Windows XP's System Restore feature is to use the registry. To use this alternative, perform the following steps:

1. Start the registry editor (regedit.exe).
2. Go to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\SystemRestore.
3. If a DisableSR value doesn't exist, go to the Edit menu, select New, DWORD value, and create the value.
4. Set the value to 1 to disable System Restore or 0 to enable System Restore.
5. Go to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\sr to prevent the System Restore service from starting.
6. Double-click Start, and set the value to 4 to stop the service from starting or to 0 for normal startup.
( I set it to 0 for normal start)
7. Close the registry editor.

RESULT:

THIS WAS NEEDED BUT DIDN'T ENABLE SYSTEM RESTORE
*********************************************

SUGGESTION 5

Start the Group Policy Editor (gpedit.msc)


Navigate to Computer Configuration/Administrative Templates/System/System Restore
Set Turn off System Restore and Turn off Configuration to Disable
Right click on My Computer and Select Manage
Navigate to Services and Applications/Services
Navigate to System Restore Service and double click
(finally, System Restore Service appears under Services)
On the General tab set [Startup Type] to Automatic using the drop down list
Click the Start button to start the service
Close the Computer Management console
Return to System Restore in Group Policy Editor and configure both to Not Configured
Close Group Policy Editor and reboot the system.

After the reboot is complete, right click My Computer, select Properties and the tab for System Restore will have been restored. Configure it to your individual needs and satisfaction.

RESULT:

SYSTEM RESTORE IS ENABLED AGAIN
*******************************************************

Thanks for all your suggestions.

John

0

I was able to turn my system restore off after completing the following instructions..make sure you are in the right folders each time..I did it in safe mode..

Resolution
1. Click Start, Run and type regedit.exe and press Enter

2. Navigate to the following key:

HKEY_LOCAL_MACHINE \ Software \ Policies \ Microsoft \ Windows NT \ SystemRestore

In the right-pane:

•Delete the value DisableConfig
•Delete the value DisableSR
3. Exit the Registry Editor

I did not find the value disableconfig in the other pane..but the second one was..it still worked for me..

Edited by trezuresnheven: n/a

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.